macOS: officially upgrade to 10.9 libraries from lib/darwin.
ClosedPublic

Authored by Brecht Van Lommel (brecht) on Sep 28 2017, 2:59 PM.

Details

Summary

We upgraded to python 3.6 in master, but did not update the old darwin libraries.
So we might as well officially do the switch now that building with the old
libraries no longer works, see T52935.

This removes a bunch of code that is no longer needed, and running "make update"
will automatically checkout the new libraries.

Diff Detail

Repository
rB Blender
This revision was automatically updated to reflect the committed changes.

You might as well delete the old libs from svn while you are at it.

They are still needed if we do a 2.79a, so we could keep them around for a bit longer I think.

They are still needed if we do a 2.79a, so we could keep them around for a bit longer I think.

that's why we have https://svn.blender.org/svnroot/bf-blender/tags/blender-2.79-release/lib , no reason to keep them around for trunk.