Page MenuHome

(Nodes) Display image name if any in the Image node title
ClosedPublic

Authored by Inês Almeida (brita_) on Jan 5 2018, 1:11 AM.

Details

Summary

As seen on the internet:

Diff Detail

Event Timeline

Inês Almeida (brita_) retitled this revision from (Compositor) Display image name if any in the Image node title to (Nodes) Display image name if any in the Image node title.

Updated, as I noticed the node on the image was actually a 'Texture Image' node instead of 'Image'. Both should work now :)

Small nit-picking about comment style. Such a small patch indeed :)

source/blender/blenkernel/intern/node.c
3185
- /* The previous methods (labelfunc) could not provide an adequate label for the node */
+ /* The previous methods (labelfunc) could not provide an adequate label for the node. */
source/blender/nodes/intern/node_util.c
96
-  /* if there is no loaded image, return an empty string, and let nodeLabel() fill in the proper type translation */
+  /* If there is no loaded image, return an empty string, and let nodeLabel() fill in the proper type translation. */

Okay, call me a noob, but I made the changes, built and I don't see that action on macOs.
Screenshots from Xcode :

Patch LGTM, and feature makes sense imho.

As @Dalai Felinto (dfelinto) noted, we try to have fully valid sentences in our comments, including end points, see also https://wiki.blender.org/index.php/Dev:Doc/Code_Style#Comments ;)

This revision is now accepted and ready to land.Jan 6 2018, 3:48 PM
Inês Almeida (brita_) marked 2 inline comments as done.

Submitted 87607254d6d

@Joel Godin (FloridaJo) maybe you have a problem in your setup? Can you see any other changes that you make? Drop by IRC #blendercoders if you need help setting up or getting patches with arcanist!

Submitted 87607254d6d
@Joel Godin (FloridaJo) maybe you have a problem in your setup? Can you see any other changes that you make? Drop by IRC #blendercoders if you need help setting up or getting patches with arcanist!

I basically cloned the repository, made changes to the individual files and then built.
After building and not seeing the change, I reexamined the individual files in Xcode (pics above) and the changes are definitely there.