Page MenuHome

Animall: Key only selected, POLY fix and fcurve groups
AbandonedPublic

Authored by Damien Picard (pioverfour) on Apr 19 2018, 6:13 PM.

Details

Reviewers
None
Summary
  • This patch allows keying only selected points for meshes, curves and lattices.
  • Fix keying POLY splines
  • Add fcurves to groups by element (Vertex, Edge, etc.), to keep the dope sheet and graph editor less cluttered
    • This does not currently work for curves: the fcurves are unassigned on switching modes. Presumably due to a bug in Blender, since it works for meshes.

Diff Detail

Event Timeline

Hello!
This doesn't seem to work on curve points. Unless I'm mistaken of course!
. Add Circle (or any sort of curves), go in Edit Mode.
. Choose point, Insert Key.
. Change frame, move point, Insert Key: The point snaps back to where it was, resulting in no animation...
Am I the only one?

Piotr

Hello!
This doesn't seem to work on curve points. Unless I'm mistaken of course!
. Add Circle (or any sort of curves), go in Edit Mode.
. Choose point, Insert Key.
. Change frame, move point, Insert Key: The point snaps back to where it was, resulting in no animation...
Am I the only one?
Piotr

Hi @Piotr Nikov (piotrnikov),
this is an old patch for Blender 2.79, is this what you are using? It works for me in 2.79.
If you are using 2.81, have you updated to the latest version of addons_contrib? I made a workaround yesterday (rBAC4ae0adbe1c048078ab7e9ce5b461d6ed14b2d57e) for a bug which prevents from inserting keyframes for curves and surfaces. The latest version is here.

If it works for you, I will close this old revision.

Hello Damien!

I updated my 2.81 this morning (with the most recent nightly build) and it still didn't work. Weird...
But I copy/pasted your recent code and it worked!
Thanks :)

Well that’s bizarre, the latest Linux nightly build works for me, and the other builds are shipped with the same version of the add-on as well. Have you installed the add-on manually from the preferences, or copied the script in your addons directory? Could there be a conflict? If so, you should delete it so that Blender uses the one from the downloaded version.

Anyway, I’m glad that it works! I will close the revision. Feel free to open a new issue and assign it to me if you encounter other bugs in animall.

Hey again,

Just downloaded the new build again and it works! Dunno what happened.
Sorry for the trouble everything is working as it should :)
Thanks so much for the prompt response and have a great day!

Piotr