Fix T55644: Changed variable names so it is possible to differentiate between input and output sockets
Thanks for the patch, but I don't think the intent of the original task was to add prefixes for In/Out. that should already be clear from the UI and not cause any problems in the Python API. Rather it was to rename to "Vector1" and "Vector2" for example.
However, if this is done there must be accompanying changes to preserve .blend backwards compatibility. It will also break Cycles and other renderers and addons.
At this point in the 2.8 development we better not make breaking changes unless there is an important reason, and I don't think this fixes an important enough issue.