Page MenuHome

Improve consistency and descriptiveness of tooltips for popovers in top right of 3D viewport
Needs ReviewPublic

Authored by Keavon Chambers (keavon) on Jun 28 2019, 10:56 AM.

Details

Summary

This patch fixes the wildly inconsistent and often unclear tooltips for the group of popover menus in the top right of the 3D viewport: Object Types Visibility, Viewport Gizmos, Viewport Overlays, Viewport X-Ray, and Viewport Shading. These were previously inconsistent between the tooltip and popover header text. For example, the overlay tooltip even mentioned "gizmos" which is not at all correct. I have put careful work into ensuring consistency between each tooltip and improving the clarity and descriptiveness of each one, which hopefully makes them significantly more useful to users. In updating "Shading" to "Viewport Shading" for consistency with the popover header/title, I also updated the pie menu title (activated from Z).

Diff Detail

Repository
rB Blender

Event Timeline

Most of these seem like improvements, except the use of the term ‘drawing mode’. We don’t use this term for display options anymore - it’s fundamentally confusing when we have actual drawing modes for users to draw in.

Instead, use ‘display’.

"Drawing" -> "Display" to eliminate ambiguity with grease pencil drawing.

Great point, I was not thinking about grease pencil which could have led to ambiguity. See this update.

This revision is now accepted and ready to land.Jun 28 2019, 11:28 AM
Brecht Van Lommel (brecht) requested changes to this revision.Jun 28 2019, 11:38 AM
Brecht Van Lommel (brecht) added inline comments.
source/blender/makesrna/intern/rna_space.c
3140

Viewport -> Show Viewport, we should not drop the verb.

3232

This description no longer explains what overlays are.

3786

The description here got lost as well, it's supposed to explain this is a toggle to enable all gizmos, as opposed to the individual toggles for different gizmo types.

This revision now requires changes to proceed.Jun 28 2019, 11:38 AM
source/blender/makesrna/intern/rna_space.c
3140

If that is the case, it will need to be prefixed with "Show/Hide" because the verb will otherwise be wrong half the time. Alternatively, "Viewport X-Ray On/Off" which is probably a better option. But I don't think it's necessary to break consistency with its neighboring toggles and only use a verb here, because the button being a toggle is obvious enough from its own presence with the blue background when clicked.

3232

It does a better job explaining now than before. We are, of course, limited to short text and cannot give a full wordy description, but this gets the idea across better. The previous phrase "like gizmos and outlines" is 50% wrong, because they are *not* gizmos, and that is extremely confusing because it is, in fact, the wrong word entirely. The other 50% "like outlines" gives only a single example, but we need at least 2–3 other examples to get the idea across descriptively. But that would be too long, and it is a bad UX to describe a feature by a subset of examples. My proposed "scene and object overlays" describes it completely (each and every overlay pertains to either the object—like outlines— or the scene—like grid lines). The only word that can describe all the types of things encompassed by that menu is, in fact, "overlays", so my approach is to narrow down the idea of overlays with the specific classifications they apply to. The user might have to click the button to get a better understanding because there isn't a highly specific English word that magically describes the entire concept, but it is way better to avoid outright confusion from an inconsistent, incomplete example that is currently in use.

3786

That is inconsistent with the overlays toggle which makes no attempt to indicate that it is a master toggle. But because of the compact design of these buttons, the user likely won't associate the tool tip for these tiny toggle buttons with the action caused from clicking the tiny button, they will instead associate the tooltip description with the function of the entire menu, so that is what it ought to describe in order to be useful and not confusing (how do the popover menu listings deal with gizmos "of all types"? and is that really the most useful way possible to describe their function?). A classification of "gizmos of all types" doesn't clear up what these "gizmo" things are as a comprehensive classification, but "interactive gizmos" goes much further towards hinting about what they are, and most importantly, how they intuitively differ from overlays, which are not interactive. That's a crucial distinction which will help users tell the two classifications apart.

Tagging @Brecht Van Lommel (brecht) because I am not sure if you got a notification of my replies to the concerns you raised.

source/blender/makesrna/intern/rna_space.c
3140

The name of the property is what it does when it's enabled. We don't call properties Show/Hide or On/Off.

Names of properties can't be set based on assumptions on how they are used in one place in the interface, they are also used for things like quick favorites and Python API docs.

We have conventions for naming properties, they should be followed until we decide to change the conventions.

3232

The description can be:

Display overlays for selection and editing on top of the scene and objects
3786

The description can be:

When disabled, hide all types of interactive gizmos in the viewport

Good points and improvements @Brecht Van Lommel (brecht). See replies and let me know your thoughts before I submit an updated diff.

source/blender/makesrna/intern/rna_space.c
3140

Thanks for the clarification, that reasoning makes perfect sense to me. I'm also going to change "Viewport Gizmos" to "Show Viewport Gizmos" and "Viewport Overlays" to "Show Viewport Overlays". However, for "Viewport X-Ray" it seems like we should be using "Enable" instead of "Show" because that is a mode that doesn't "show" anything, per se, but it enables a modification to what is already shown (so that the scene becomes shown using the x-ray feature).

And likewise, should I change "Snap" into "Enable Snap" and "Proportional Editing Objects" into "Enable Proportional Editing"?

If the prefix "Enable" isn't part of the naming conventions like "Show" is, then that could still work but it seems a bit less clear to people reading it.

(By the way, interestingly the Viewport X-Ray button actually is missing the option to add it to quick favorites.)

3232

How about Display scene and object overlays for selection and editing? Because that implies they are overlays *about/related to* the scene and objects (as they are "scene and object overlays", and thus also overlaid over the scene and objects), which then encompasses the concept that overlays also include things like the grid and axes, but then it includes your suggested description about "selection and editing" to help the user understand also their purpose. This is also shorter:

Display overlays for selection and editing on top of the scene and objects
vs.
Display scene and object overlays for selection and editing

3786

That definitely sounds better! I shortened it slightly from:
When disabled, hide all types of interactive gizmos in the viewport
to:
When disabled, hide all interactive viewport gizmos

  • gizmos in the viewport is shorter as just viewport gizmos
  • hide all types of is shorter as just hide all because they both describe the same result (in either case, it says all the gizmos are hidden)

@Brecht Van Lommel (brecht) I'm submitting this diff since I have not heard back on my replies to your comments, please read those and see if this diff now has wording that is satisfactory or otherwise let me know! Hopefully this can get added before the release candidate.

This revision is now accepted and ready to land.Jul 8 2019, 7:50 PM
This revision now requires review to proceed.Jul 8 2019, 7:50 PM

@Keavon Chambers (keavon) The word 'enable' is implicit in the fact that it is a toggle with a checkmark. The checkmark already communicates 'enable' or 'disable'. We put 'Show' in front of items to clarify that it is a display option.

Enable Viewport X-Ray -> Show Viewport X-Ray

Thanks for the clarification on that detail @William Reynish (billreynish), that sounds sensible! Hopefully these changes are now agreeable for everyone. I understand the last minute changes going into the release candidates is for bug fixes so if this can't be slipped into RC2 then hopefully it can make an appearance for 2.81 in a few months!