Here is my port of T30941 to blender 2.8.
This adds the ability to simulate air pressure inside a closed cloth surface.
I think it should be good to go. Perhaps a bit more polishing on the UI is needed.
I think this property names can be improved. cloth_pressure does not make much sense to me. Why not just call it something like air_pressure_difference?
For the others: initial_volume and pressure_factor (factor seems to fit better than scale here imo).
Don't shorten names unnecessarily.