Page MenuHome

Rename cut operator
ClosedPublic

Authored by Nathan Lovato (gdquest) on Aug 20 2019, 5:06 PM.

Details

Summary

Closes https://developer.blender.org/T68690

I've only renamed the operator in Blender. Should I rename cut->split in sequencer_edit.c for consistency with the source code?

Diff Detail

Repository
rB Blender

Event Timeline

Rename cut operator function to split

Yes, should be renamed in internal code too, the keymap needs updating.

Rename cut->split in source code, rename cut multicam to split, update keymap

I also renamed cut_multicam to split_muticam, compiled and tested in the vse
I went ahead and renamed all cutframe variables to split_frame, even in cut_seq_list as it's used in the split functions.

Everything looks good to me, but am not able to test at the moment.

  • Update to master

Fine with this. This removes the ambiguity between it and Cut/Copy/Paste.

This revision is now accepted and ready to land.Feb 5 2020, 10:52 AM
This revision was automatically updated to reflect the committed changes.