Page MenuHome

Transform: Split `transform_conversions` into multiples files
ClosedPublic

Authored by Germano Cavalcante (mano-wii) on Wed, Sep 4, 6:16 PM.

Details

Summary

Part of T68836

All functions that start with createTrans... and flushTrans... have been moved to the corresponding data type.
Functions in transform_conversions.c that are exposed in transform.h are now exposed in transform_conversion.h.

Diff Detail

Repository
rB Blender

Event Timeline

Germano Cavalcante (mano-wii) edited the summary of this revision. (Show Details)
Germano Cavalcante (mano-wii) retitled this revision from Transform: Cleanup: Move Mesh conversion to its own header to Transform: Cleanup: Move Mesh conversion to its own file.Wed, Sep 4, 6:23 PM
Germano Cavalcante (mano-wii) edited the summary of this revision. (Show Details)

Looks good, think these kind of changes could be made in a branch, then committed at once (split up each type into its own file).

  • Transform: Move Amrmature conversion to its own file
  • Transform: Move Cursor Conversion to its own file
  • Transform: Move Mball conversion to its own file
  • Transform: Move Curve conversion to its own file
  • Transform: Move Lattice conversion to its own file
  • Transform: Expose Tranform conversion utils in its own header
  • Transform: Move Particle conversion to its own file
  • Transform: Move Edge and UV conversion to transfom_conversion_mesh
  • Transform: Move ActionData conversion to its own file
  • Transform: Move NLA conversion to is own file
  • Transform: Move graph editor conversion to its own file
  • Transform: Move Sequencer conversion to its own file
  • Transform: Move Object conversion to its own file
  • Transform: Move Texture Space conversion to its transform_conversion_object
  • Transform: Move node conversion to its own file
  • Transform: Move Tracking conversion to its own file
  • Transform: Move Mask conversion to its own file
  • Transform: Move rush conversion to its own file
  • Transform: Move Gpencil conversion to its own file
  • Transform Move each flushTrans... to its respective file.

Would call transform_conversions_brush.c > transform_conversions_paintcurve.c, besides this LGTM.

Suggestion, conversions made sense for many, we could call these:

transform_convert_action.c, transform_convert_mesh.c, ... etc.

Germano Cavalcante (mano-wii) retitled this revision from Transform: Cleanup: Move Mesh conversion to its own file to Transform: Split `transform_conversions` into multiples files.Thu, Sep 5, 4:47 PM
Germano Cavalcante (mano-wii) edited the summary of this revision. (Show Details)
  • Rename transform_conversions_... to transform_convert_...
  • Rename transform_convert_brush.c > transform_convert_paintcurve.c
  • Rearrange Header
This revision is now accepted and ready to land.Thu, Sep 5, 7:14 PM