Using the words element and target are more descriptive and are easier to describe to someone than using snap to/with.
I don't think this regression is a good idea, considering the amount of support that the RightClickSelect proposal gathered in the first place, and the consensus around this in the recent patch that Germano mentioned.
That way, it looks like you're snap "Snap Element" to "Snap Target".
Read also "snap_target" tooltip: “Which part to snap onto the target”, i.e. target is the "snap_elements".
And also the "Align Rotation to Target".
I think the existing labels do a better job explaining what these do. "Target" to me implies the opposite of what it actually does, and modifiers and contraints also use it in the opposite way.
Internally the logic of snap_elements and snap_target are a bit reversed which is what is really confusing. Reversing these makes sense:
Target (could also be called method)
The resulting point to snap the object to
The part of the object to use for snapping.
The main goal of this patch as @Germano Cavalcante (mano-wii) pointed out is to follow the convention of using nouns for labels.