Page MenuHome

Sequencer: Clean Up Menus

Authored by Peter Fog (tintwotin) on Fri, Jan 24, 12:42 PM.



Several new functions has been added to the VSE menus since the last round of vse-menu-housekeeping, making the menus more cluttered and higher than needed.

View Menu:

  • Rename to "View All", rename to "View Selection", rename to "Go to Current Frame"(and move), for consistency.
  • Remove separators in the Show-section to make the menu as short as possible.
  • Insert separator between show-section and "Sync Visible Range", since everything in show-section relates to the visuals of the Sequencer.



Select Menu:

  • In Channel sub-menu: Move "Both Sides" up and remove separator in consistency with the Handle submenu.



Add Menu

  • Add Modifiers.



Strip Menu:

  • Remove Copy Modifiers to Selection, since it is already in the Modifiers panel in the Sidebar, where the user actually can see what modifiers are copied.
  • Move Add Modifier to Add menu.



Context Menu:

  • Move Active Strip options above Add Transition and Add Fade.
  • Rename Fade to Add Fade.
  • Replace Transform sub menu with Transform options, for simplicity.
  • Move Rename below Delete.
  • Insert Duplicate icon in consistency the context menu for cubes.
  • Renamed "Clear Fade" with "Delete Fades".
  • Renamed "Crossfade Sounds" to "Add Crossfade", since it is only available with Sound Strips.(Add Transition is still available with ex. movie strips)
  • Removed the separators between Add elements.



Diff Detail

Event Timeline

Peter Fog (tintwotin) edited the summary of this revision. (Show Details)

Re-added Modifier to Context Menu and renamed "Clear Fade" with "Delete Fades" and renamed "Crossfade Sounds" to "Add Crossfade", since it is only available with Sound Strips. And Removed the seperators between add elements.

William Reynish (billreynish) requested changes to this revision.Fri, Jan 24, 8:11 PM

Some of these changes seem fine, but currently we don't use consistent names for view_all and view_selected operators. Sometimes we call these Frame All and Frame Selected - I think we should find a consistent name for these across the UI.

Also, we should try not to override names in the UI scripts, but simply change the UI names in RNA. We should only overwrite the RNA UI names in cases when necessary.

The context menu should probably also follow the overall same concept as in other editors, grouping items into add/edit/remove sections. Again, some name changes seem ok but should probably not be done at this level.

This revision now requires changes to proceed.Fri, Jan 24, 8:11 PM

Where do you experience that there is too much difference between the name of the operator and the menu entry?
This is the old code:

layout.operator("sequencer.view_selected", text="Frame Selected")
layout.operator("sequencer.view_all", text="Frame All")

Where the API and the Menu Text entries are not the same, in the patch they get the same name.

The only place where the operator and the Menu text is slightly divergent is here:

layout.operator("sequencer.crossfade_sounds", text="Add Crossfade")

But here the menu text is changed to be in consistency with the menu naming convention.


layout.operator("sequencer.fades_clear", text="Delete Fades")

Which again, is an attempt is to stay in the consistency with the menu naming conventions.

Are there any context menus you would recommend to use as template for the order of things? Maybe the strip specific elements could be moved to the top of the menu, like in the panel?

One issue is that generally, we use different UI names for Frame Selected and Frame All. We should address that.

Another issue is that sometimes we change the UI names in the UI Lay-out rather than changing it in the RNA UI name.

The third issue is that the context menu here seems to be a bit inconsistent with other editors in terms of the ordering.

I’m sure we can address the three issues mentioned here.

Abandoning this in place of this patch which just moved the Add Modifier to the Add Menu instead: