Page MenuHome

Flamenco 3.0 Beta 2 - Cached job type is old, job rejected
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.19043-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 516.94

Blender Version
Version: 3.2.2, branch: master, commit date: 2022-08-02 18:15, hash: rBbcfdb14560e7

Flamenco Version
flamenco-3.0-beta2-windows-amd64.zip

Short description of error
At job submission I get this error message, and the job is rejected: "Cached job type is old. Refresh the job types and submit again, please"
I don't understand, find, how to "refresh" the job types.

Exact steps for others to reproduce the error
I downloaded the latest Beta 2 version of Flamenco, as well as the related Blender add-on.
As per my previous bug report (T100226) I kept the same folders structure and deleted everything but the test file inside D:\Flamenco\projects;
copied the new beta2 version's files inside D:\Flamenco\software\flamenco;
deleted the worker's configuration files inside C:\Users\Riccardo\AppData\Local\Blender Foundation\Flamenco;
started the Flamenco Manager and successfully configured it to run Blender from D:\Blender_3.2_stable\blender.exe, as well as downloaded the latest add-on for Blender from the link available in the Manager Web interface;
started the Flamenco Worker, successfully finding my laptop as an available worker;
started Blender 3.2.2, installed the latest Flamenco add-on, and opened the test file inside D:\Flamenco\projects.

Clicking on the button to send the job to the Manager I get the following error messages in the Blender Scripts console:
"Cached job type is old. Refresh the job types and submit again, please"

In the Manager console I get this error message:
WRN rejecting submitted job, job type etag does not match error="job type etag does not match: expecting \"3120b88aa98c62b463c684ede08ddabe9dd1e764\", submitted job has \"d58dbf05dd8acdc6dc8c2710a0209a0bade7045c\"" name=test type=simple-blender-render

I don't know how to "refresh the job types" and I don't see this option in the Web Interface either. Tried to resend the job as well as to reinstall everything from scratch one more time, as per above description, but I always get the same error and job rejection.

These are the Flamenco Manager configuration files inside D:\Flamenco\software\flamenco:


These are the Flamenco Worker configuration files inside C:\Users\Riccardo\AppData\Local\Blender Foundation\Flamenco:


This is the test file inside D:\Flamenco\projects:

Revisions and Commits

Event Timeline

The Flamenco Beta 3.0 just came out (yesterday). Can you confirm if the problem persist there? Thanks

Hi Dalai,

I downloaded and tested Flamenco 3.0 Beta 2 yesterday. In case, this afternoon (I'm at work now) I can redo from scratch these tests after downloading the current beta, but I presume it is the same as the one I downloaded yesterday. Let me know if I should proceed.

Regards,
Riccardo

Hi Riccardo. If you downloaded the Beta 2 it is indeed the old one. The Beta 3 was released late yesterday.

OK, I will retest it and let you know the results.

This is expected behaviour. The Manager has changed, and because of that the data cached by Blender is outdated. This system prevents you from submitting a job with outdated settings. Just click the 'refresh' button next to the job type select box, and it should work. Be sure to save the file after refreshing.

I confirm that Flamenco Beta 3 works as expected. (You can stop reading here, for the purpose of the bug report.)

The only problem I have, at the moment, is related to its naming conventions of the rendered job folders and files, but hopefully this will be made customizable in the future.

In our small production, we need to name each rendered frame/file using a prefix for the shot, needed for proper editing (in DaVinci Resolve) and post-processing. Currently, Flamenco creates a folder with the Job Name (eg. D:\Flamenco\renders\test2\) and a subfolder for each render task/instance named with the date and time (eg. D:\Flamenco\renders\test2\2022-09-01_170734), and inside it all files are named just with a frame number of 6 digits (eg. 000001.png). Obviously, the Job Name in Blender can be named with the shot number (eg. D:\Flamenco\renders\s01_01\2022-09-01_170734) but then the created subfolder (\YYYY-MM-DD_time) adds complexity to the path and the files don't have a meaningful name, for our purpose. Hopefully, this might change in the future, allowing customization of paths and/or rendered file naming.

For your information, Flamenco renders also OpenEXR files, which is what we need in production but, obviously, doesn't create a video from them, which anyway we don't need, but it's instead useful when we render animatics of the shots using PNG format. Thank you.

One question. How would you manage to render shots from a production folders structure like the one below, with all data linked inside the shot's .blend files? Currently, it seems to manage only files inside the D:\Flamenco\project folder, which is good for a single Blender file project but not for a real production with linked data as ours. Thank you.

Sybren A. Stüvel (sybren) closed this task as Resolved.Sep 1 2022, 7:33 PM
Sybren A. Stüvel (sybren) claimed this task.

The only problem I have, at the moment, is related to its naming conventions of the rendered job folders and files, but hopefully this will be made customizable in the future.

That's already customisable :)

https://flamenco.blender.org/usage/job-types/ has a little primer on how that's done.

For your information, Flamenco renders also OpenEXR files, which is what we need in production but, obviously, doesn't create a video from them, which anyway we don't need, but it's instead useful when we render animatics of the shots using PNG format. Thank you.

Glad to hear that!

One question. How would you manage to render shots from a production folders structure like the one below, with all data linked inside the shot's .blend files? Currently, it seems to manage only files inside the D:\Flamenco\project folder, which is good for a single Blender file project but not for a real production with linked data as ours. Thank you.

That should work just fine as well with Flamenco. You can read more on the different storage methods on https://flamenco.blender.org/usage/shared-storage/.

If you have more questions, please write me on the #flamenco chat channel; we shouldn't be using this bug report as further discussion forum ;-)

Thank you very much, Dr. Sybren!