Constraints locked on linked armatures
Closed, ArchivedPublic


Group: current SVN version
Resolution: Fixed
Category: Tools

Constraint data on linked Armature Data (as in Shift+F1
Link from another .blend) is incorrectly linked to the
armature instead of the action.

Basically what this means is you can't edit the
constraints inside a linked Armature, for example use
the same armature but turn on/off or add an IK solver
depending on the scene.

To reproduce:

1) Create an Armature and save the file.
2) Create a new file and link the just-saved Armature
Object (as in Library.blend > Objects > Armature) into
the scene
4) Create a NEW Armature
5) Link the new Armature to the Armature Data of the
linked one.
6) try to add a constraint to the new armature! =)

All versions starting with 2.30 will stop you saying
"ERROR: Can't edit library data", whereas any version
up to 2.28 allows it.

Funny thing is, you can add and animate a constraint on
a linked Armature in 2.28, open it up in 2.3+ and be
able to move the keyframes for it in the Action window.

You can't actually edit the constraint's IPO in 2.3+
however, but if the IPO was pinned back in 2.28, it can
be edited just like any other IPO.

I've uploaded a zip with blend files of the above
steps. Please place the blend files in c:\blender so
the library can be accessed correctly.

Finally, my system:
Windows 2000 Pro SP4
Geforce 3 ti200 64mb

Tested with:
Blender 2.28, 2.30, 2.32, and Bf-Blender build from
April 5, 2004


Ton Roosendaal (ton) closed this task as "Archived".Via Old WorldApr 11 2004, 3:52 PM
Nobody (None) added a comment.Via Old WorldApr 7 2004, 6:57 PM

This task was automatically closed as archived as part of migration, because the project or tracker this task belonged to is no longer active.

Add Comment