Constraints lag in rendered animation
Closed, ArchivedPublic


Group: current SVN version
Resolution: Investigate
Category: Rendering (intern)

Hi. I'm running into a problem with constraints in a
rendered animation. The setup I have renders fine with
the OpenGL renderer (both directly in the 3d window or
when written to disk as an animation) or as still
images with the software renderer, but if I try to
render it as an animation using the software renderer,
some constraints lag a frame behind.

I tried to setup the system again by hand to invoke the
bug, but to be honest, I couldn't. I'm certain it's a
bug however because it's reproducable every time in my

To see the bug in action, please open my file and:

1) Scrub through frames 40-50 or so. Notice how the
hands are more or less at the bottom of the saw when
it's coming down.

2) Render a still frame when the saw's coming down, say
frame 47. Still looks good, right :)

3) Render frames 40-50 as an animation. Notice how the
hands incorrectly lag behind- they're around the middle
of the saw when they should be at the bottom.

I'm running:
Windows 2000
Geforce 3 ti200

Tested with:
Blender 2.30, 2.32, April 21 BF build


Chris Want (hos) closed this task as "Archived".Via Old WorldApr 21 2004, 4:19 PM
Nobody (None) added a comment.Via Old WorldApr 21 2004, 7:54 AM

This task was automatically closed as archived as part of migration, because the project or tracker this task belonged to is no longer active.

Add Comment