Page MenuHome

Import svg error
Closed, InvalidPublic

Description

Resolution: Fixed
Category: Scripts

Blender 2.48
Pyton 2.5.2

Console python error (Pantallazo.jpg)

Event Timeline

Bug is caused by scientific notation numbers in the SVG file (8e-5). Float() can convert that correctly but the script tokenizes it like crap and remove the -5.

Cambo, will you communicate with jms about this? Just send him the svg and see if he can deal with his own messy code.

It seems that the last inkscape version can save in two svg formats.

You have to rename the import menu entry in "simple svg" instead of "inkscape (.svg)" because there is no import problem if the demo file is saved in the simple svg format.



The corrected script is available there :
http://jmsoler.free.fr/didacticiel/blender/tutor/cpl_import_svg_en.htm

That's the second correction made since november 2008 and the script always waits for an update in the svn.

Campbell Barton (campbellbarton) changed the task status from Unknown Status to Unknown Status.Feb 13 2009, 8:12 AM

This task was automatically closed as archived as part of migration, because the project or tracker this task belonged to is no longer active.