Adding a new empty screen cause a segmentation fault <- Compiz error
Closed, ArchivedPublic

Description

Hi,

I use Blender 2.48a downloaded from Blender site.
My PC system is Ubuntu Linux Intrepid (8.10) 32 bit, 2GB RAM
My graphic card is NVidia QUADRO FX 1500M


When I try to add a new empty screen, Blender exit with a Segmentation fault. The complete message is here:
-------------------------------------------------------
Compiled with Python version 2.5.2.
Checking for installed Python... got it!
No 3Dconnexion driver is running.
error in areawinar 6 ,areawinset
error in areawinar 9 ,areawinset
Segmentation fault
-------------------------------------------------------

Instead when I add a duplicate screen all function well.

alorom (Nicola Jelmorini) set Type to OpenGL Error.Via Old WorldNov 24 2008, 7:47 PM
None (Nobody) closed this task as "Archived".Via Old WorldNov 24 2008, 7:47 PM
ton (Ton Roosendaal) added a comment.Via Old WorldNov 27 2008, 5:08 PM

Cannot redo here, but it might depend on the .B.blend or .blend file you loaded when you add a new screen... try to pin down what exactly causes it?

alorom (Nicola Jelmorini) added a comment.Via Old WorldNov 27 2008, 8:27 PM

Ok, I have some news about.

I have deleted my .B.blend file, so I can run Blender with default setting.

First test:
-----------
Starting blender without options I have no window border. Even starting Blender with "-w" option I have no window border. Trying to add a new empty screen in this case function well.

Second test:
------------
I have started blender with "-p 0 0 1000 1000" option and only in this case Blender start with window border. Trying to add a new empty screen in this case cause the segmentation fault problem.

So for now I have determined the cause of the problem, but why Blender open without window border? And why the segmentation fault problem is present only when I force window border with the "-p" option?

On my Ubuntu system I have activated the Compiz-fusion window manager. Perhaps is this the problem? YES.
I have turned off Compiz-fusion and activated the standard Metacity window manager. Now Blender start correctly with window border, and adding a new empty screen function well without segmentation fault.

Finally I can say that the problem is resolved without Compiz, but is present with Compiz.

ton (Ton Roosendaal) added a comment.Via Old WorldNov 28 2008, 10:19 AM

thanks for testing.
Compiz is indeed conflicting with opengl sometimes, but I heard it works fine in many cases too, especially for nvidia cards.

letterrip (Tom Musgrove) added a comment.Via Old WorldMar 21 2010, 10:31 PM

This is a generic request to test your bug report and see if it is still an issue in 2.5alpha2 if so please let me know by making a comment in this report ie 'also in 2.5alpha2' and I will add it to the 2.5 bug list.

alorom (Nicola Jelmorini) added a comment.Via Old WorldMar 21 2010, 11:34 PM

Hi Tom,

I have tried with Blender 2.5alpha2 64bit, but this problem not happened again.
I use now Ubuntu 9.10 64bit with Compiz activated, and Blender function very well.

Add Comment