Home

Blender2.5 is not able to load bpy_ops.py and all the ui/* scripts
Closed, ResolvedPublic

Description
On Linux if I compile Blender v2.5 it runs perfectly only if I launch it from the directory where I have compiled the sources; indeed if I try to package blender v2.5 for my distro, installing the blender binary into /usr/bin, all the python scripts into /usr/share/blender/scripts, all the UI scripts into /usr/share/blender/ui and all the IO scripts into /usr/share/blender/io, the blender binary runs but the menu are not loaded as viewable by the attached image. I got also these errors on the console output:

search for unknown operator CONSOLE_OT_execute, CONSOLE_OT_execute
search for unknown operator CONSOLE_OT_execute, CONSOLE_OT_execute
search for unknown operator CONSOLE_OT_autocomplete, CONSOLE_OT_autocomplete

Doing some simple testing I was able to figure out the issue: the blender binary just try to search bpy_ops.py and all the the other UI python scripts from the *relative* path ./release/ui, if it find them the menu are loaded, otherwise you got the scenario previously exposed.

I was able to temporarely fix the problem with a stupid shell script, but I doubt that this is the intended beaviour of the application; most probably the right solution is to let blender binary to search the UI scripts into the *absoluth* path: /usr/share/blender.

Attached there is screenshot and a copy of the user-config.py used to compile Blender.
Hope to be useful.
Mauro Toffanin
brecht (Brecht Van Lommel) added a comment.Via Old WorldSep 21 2009, 4:13 PM
A compile option for this has been added recently:
http://lists.blender.org/pipermail/bf-blender-cvs/2009-September/022573.html
brecht (Brecht Van Lommel) closed this task as "Resolved".Via Old WorldSep 21 2009, 4:13 PM
equilibrium (Mauro Toffanin) added a comment.Via Old WorldSep 23 2009, 4:39 PM
Thank you very much Brecht Van Lommel, I can confirm that Scons options WITH_BF_FHS + BLENDERPATH solve the issue and finaly it's possible to package Blender for source-based distros (Gentoo, Arch, Funtoo, Exherbo) in a decent way without the use of stupid-and-dirty hacks.

Kudos for the work.

Add Comment