Page MenuHome

Crash opening user preferences
Closed, ArchivedPublicKNOWN ISSUE

Description

Blender crash if I choose menu itme File->User Preferences. It doesn't crash if I use keyboard shortcut or "User Preferences" window type.

To reproduce, choose that menù item in any cotext.

Here is the error reported in the terminal:
AttributeError: expected Operator class to have an "bl_idname" attribute
blender: radeon_lock.c:65: radeonGetLock: Assertion `drawable != ((void *)0)' failed.
Aborted

Blender svn revision: 24755
Linux 2.6.31 (Ubuntu 9.10) 32 bit
ATI Mobility Radeon Express 200M (R300 family) with open source driver.

Event Timeline

Nobody (None) changed the task status from Unknown Status to Unknown Status.Nov 22 2009, 1:06 PM

I cannot reproduce this with r24798 on ubuntu 9.10 64bit intel graphics (current mesa master through xorg-edgers ppa).

Could this be a bug in the radeon open source driver? You can find this out by starting blender like this in a terminal window:
LIBGL_ALWAYS_SOFTWARE=1 /path/to/blender
Does it still crash, then?

Does rendering to a new window crash as well? Or duplicating a window (ctrl alt W)?

I'm guessing this may be due to a bug in the radeon drivers:
http://bugs.freedesktop.org/show_bug.cgi?id=22851

Closed duplicate reports:
http://projects.blender.org/tracker/?func=detail&atid=498&aid=19886&group_id=9
http://projects.blender.org/tracker/?func=detail&aid=20097&group_id=9&atid=498

Sorry for the late reply. Missed the email notification somehow and only saw your questions today.

The LIBGL_ALWAYS_SOFTWARE=1 doesn't crash.

Duplicating the window doesn't crash either.

Setting the Window Draw Method from Triple Buffer to Overlap fixes the terrible slowlyness, but doesn't fix the crash when opening the User Preferences without the LIBGL-Setting above.

No crash with driver Mesa 7.6.1-rc3.

Delete trunk/build/linux2 and rebuild.
AttributeError: expected Operator class to have an "bl_idname" attribute shows that you have out of date files in the build dir.

pardon me it is trunk/install/linux2

Hi,

There was a crash on opening user preferences fixed recently. Can you please try again with an up-to-date SVN build and see what happens?

Current SVN revision is : 26070

rev26303, ubuntu 9.10 32-bit, ati proprietary drivers, HD 4770
cannot reproduce this
regards

This is a driver bug as indicated by the bug report I linked to earlier, that is fixed in newer versions of the radeon drivers. I don't know when that will arrive in linux distributions, but there is nothing we can do about it at the moment, so moving to opengl errors tracker.

This is a generic request to test your bug report and see if it is still an issue in 2.5alpha2 if so please let me know by making a comment in this report ie 'also in 2.5alpha2' and I will add it to the 2.5 bug list.

It affects also 2.5alpha2. But it seems to be a X driver issue.