Page MenuHome

Crash when Sculpting
Closed, ArchivedPublic

Description

I can't really figure out, what triggers this, however, here's the backtrace. I have multires modifier with 2 layers on the mesh.

Program received signal SIGSEGV, Segmentation fault.
0xb63b9d38 in ?? () from /usr/lib/dri/i965_dri.so
(gdb) where
#0 0xb63b9d38 in ?? () from /usr/lib/dri/i965_dri.so
#1 0xb63b7524 in _tnl_run_pipeline () from /usr/lib/dri/i965_dri.so
#2 0xb63b7b35 in _tnl_draw_prims () from /usr/lib/dri/i965_dri.so
#3 0xb63b8506 in _tnl_vbo_draw_prims () from /usr/lib/dri/i965_dri.so
#4 0xb63b0fdf in vbo_rebase_prims () from /usr/lib/dri/i965_dri.so
#5 0xb63b7f11 in _tnl_draw_prims () from /usr/lib/dri/i965_dri.so
#6 0xb62e8f68 in brw_draw_prims () from /usr/lib/dri/i965_dri.so
#7 0xb63af750 in ?? () from /usr/lib/dri/i965_dri.so
#8 0xb63af80e in ?? () from /usr/lib/dri/i965_dri.so
#9 0xb63a6e4d in ?? () from /usr/lib/dri/i965_dri.so
#10 0x0871fda0 in GPU_draw_buffers (buffers_v=0xa5daa88)
at source/blender/gpu/intern/gpu_buffers.c:666
#11 0x08ba8e10 in BLI_pbvh_node_draw (node=0xb6a431c, data=0x0)
at source/blender/blenlib/intern/pbvh.c:1254
#12 0x08ba73ca in BLI_pbvh_search_callback (bvh=0xa8e14b8, scb=0,
search_data=0x0, hcb=0x8ba8df1 <BLI_pbvh_node_draw>, hit_data=0x0)
at source/blender/blenlib/intern/pbvh.c:710
#13 0x08ba8fa5 in BLI_pbvh_draw (bvh=0xa8e14b8, planes=0x0, face_nors=0x0)
at source/blender/blenlib/intern/pbvh.c:1298
#14 0x088c5e27 in ccgDM_drawFacesSolid (dm=0xb2455d8,
partial_redraw_planes=0x0, fast=0,
setMaterial=0x8712cf5 <GPU_enable_material>)
at source/blender/blenkernel/intern/subsurf_ccg.c:1249
---Type <return> to continue, or q <return> to quit---
#15 0x0843525b in draw_mesh_fancy (scene=0xa4156b0, ar=0xa3f70e8,
v3d=0xa3f7578, rv3d=0xa3f7210, base=0xa415c78, dt=3, flag=3)
at source/blender/editors/space_view3d/drawobject.c:2819
#16 0x08435bc6 in draw_mesh_object (scene=0xa4156b0, ar=0xa3f70e8,
v3d=0xa3f7578, rv3d=0xa3f7210, base=0xa415c78, dt=3, flag=3)
at source/blender/editors/space_view3d/drawobject.c:2999
#17 0x0843e7c9 in draw_object (scene=0xa4156b0, ar=0xa3f70e8, v3d=0xa3f7578,
base=0xa415c78, flag=3)
at source/blender/editors/space_view3d/drawobject.c:5761
#18 0x08427e8e in view3d_opengl_select (vc=0xbffff1dc, buffer=0xbffd80dc,
bufsize=10000, input=0xbffd806c)
at source/blender/editors/space_view3d/view3d_view.c:1222
#19 0x084578ac in mixed_bones_object_selectbuffer (vc=0xbffff1dc,
buffer=0xbffd80dc, mval=0xa6940a0)
at source/blender/editors/space_view3d/view3d_select.c:952
#20 0x08457df6 in mouse_select (C=0x94c20b0, mval=0xa6940a0, extend=0,
obcenter=0, enumerate=0)
at source/blender/editors/space_view3d/view3d_select.c:1053
#21 0x084599a9 in view3d_select_invoke (C=0x94c20b0, op=0xb53bfa0,
event=0xa694090)
at source/blender/editors/space_view3d/view3d_select.c:1695
#22 0x083e89b3 in wm_operator_invoke (C=0x94c20b0, ot=0x9534178,
event=0xa694090, properties=0x9619a58, reports=0x0)
---Type <return> to continue, or q <return> to quit---
at source/blender/windowmanager/intern/wm_event_system.c:429
#23 0x083e9ba6 in wm_handler_operator_call (C=0x94c20b0, handlers=0xa3f71d0,
handler=0xa309b30, event=0xa694090, properties=0x9619a58)
at source/blender/windowmanager/intern/wm_event_system.c:932
#24 0x083ea2ff in wm_handlers_do (C=0x94c20b0, event=0xa694090,
handlers=0xa3f71d0)
at source/blender/windowmanager/intern/wm_event_system.c:1133
#25 0x083eaa97 in wm_event_do_handlers (C=0x94c20b0)
at source/blender/windowmanager/intern/wm_event_system.c:1328
#26 0x083ee928 in WM_main (C=0x94c20b0)
at source/blender/windowmanager/intern/wm.c:325
#27 0x083e2f1e in main (argc=2, argv=0xbffff674)
at source/creator/creator.c:900

Event Timeline

r25357
Intel GM965/GL960
Linux 2.6.30-2-686

The backtrace indicates that it happened when you used mouse selection, i.e. RMB click while in sculpt mode. It is crashing using VBO's in GL_SELECT mode. If you enable VBO in the user preferences, and try to select objects, does it crash as well?

I gave this a quick try, but no crashes or problems with VBOs enabled in object or edit mode, as far as I can see.

I gave this a quick try, but no crashes or problems with VBOs enabled in object or edit mode, as far as I can see.

I gave this a try and could not duplicate it. However, I'm running
XP SP3
Intel 965 Mobile Graphics With the there Accelerator driver for OpenGL

I am having this same issue

OSX 10.5.8
2.33 ghz intel core 2 duo 3 gig of ram
macbook pro 2,1 17 "

I crash whenever I try to do anything in sculpt mode. Sometimes it will do one or two things, and then it crashes.

I tried the VBO checkbox in the setting, and it doesn't seem to do anything.

I also have a mac running 10.4.11 dual 2ghz power pc g5 with 1 gig of ram that I'm running a different build of 2.5 and I get the same issue on that machine. When I have a simple model (ie a cube with a subsurface modifier ) it takes a little more work to make it crash, but it still does after 6 or 7 sculpts.


Let me update, after messing with this more. I have both a subsurface and mirror modifier on my object. If I leave either of them on, then blender crashes when I attempt to sculpt the object.

If I apply both modifiers, and then use the sculpting tools, everything is fine.

If that helps at all.

The subsurf modifier is known to cause crashes with sculpt from other reports so this might be a duplicate

The subsurf modifier problem is indeed a separate problem. For the other crash, is this still a problem? There are no steps to redo this problem in the original bug report, so if there's not more specific information I'll have to close this report.

Brecht Van Lommel (brecht) changed the task status from Unknown Status to Archived.Feb 6 2010, 6:24 PM