Page MenuHome

Segfault after File -> New
Closed, ResolvedPublic

Description

OS: Ubuntu 8.04
Revision: 25637

libopenal (not sure if/how this is related, see backtrace below):
ii libopenal-dev 1:0.0.8-7 OpenAL is a portable library
for 3D spatiali
ii libopenal0a 1:0.0.8-7 OpenAL is a portable library
for 3D spatiali

I get a segmentation fault when I go to File -> New in the latest revision. (I do not get this problem with the official Blender 2.5 Alpha 0 release). It appears to be partially related to the ~/.B25.blend file (which didn't exist).
If I put an arbitrary .blend file as .B25.blend I don't experience the crash.

Attached is the output from an strace.

I compiled it with BF_DEBUG and used gdb:

(gdb) run
Starting program: /home/jc/blender-svn/blender2.5/install-debug/linux2/blender
[Thread debugging using libthread_db enabled]
[New Thread 0xb6d09920 (LWP 19221)]
[New Thread 0xb63b2b90 (LWP 19224)]
found bundled python: /home/jc/blender-svn/blender2.5/install-debug/linux2/.blender/python
[Thread 0xb63b2b90 (LWP 19224) exited]
[New Thread 0xb63b2b90 (LWP 19229)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb6d09920 (LWP 19221)]
0xb7d40b93 in ?? () from /usr/lib/libopenal.so.0
(gdb) bt
#0 0xb7d40b93 in ?? () from /usr/lib/libopenal.so.0
Cannot access memory at address 0x5
(gdb) quit

Details

Type
Bug

Event Timeline

Your OpenAL version is 0.0.8, this version is not supported, update to at least OpenAL soft 1.3 (1.10 is current).

Joerg Mueller (nexyon) closed this task as Resolved.Jan 4 2010, 9:12 AM

Moreover it's a duplicate of https://projects.blender.org/tracker/index.php?func=detail&aid=19685&group_id=9&atid=498

Thanks for your effort, but your issue has been reported already.