tablet pressure glitch: beginning of strokes at full pressure
Closed, ResolvedPublic

Description

When I begin to draw a stroke with my tablet in blender, the beginning of each stroke is at full pressure, even through I'm barely touching the tablet surface.

From this I guess that the problem is that before it receives any pressure data from the tablet, blender assumes the pressure to be at full value, when it should assume the pressure to be zero, or else same as the last data received.

The problem disappears when I do something to slow blender down, like painting on a complicated mesh in texture face mode. Presumably when blender is slow that faulty initial data never gets a chance to be applied to the texture, because blender takes longer to initiate the stroke.

I've encountered this bug in all versions of blender I've found, on multiple computers and with multiple tablets and multiple stylii.

I'm using a 2.8 GHz mac book pro (intel Core 2 Duo) running OSX 10.6 and a GeForce 9400M GT.

My tablet is a Wacom Bamboo Fun CTE-650.

The problem appears in every version of blender with tablet pressure and texture paint, including the latest version and 2.5.

My tablet works fine in other drawing programs.

Attached is a picture of what the problem looks like, and a blender setup I'm using at the moment in which it appears.

Thanks. Good luck.

Brecht Van Lommel (brecht) added a comment.Via Old WorldFeb 13 2010, 12:43 PM

Thanks for the report. This is indeed an old issue but no developer has been able to redo it yet, it seems to be related to specific tablets or configurations.. Also closed another report on this recently, will leave this one open instead.
http://projects.blender.org/tracker/index.php?func=detail&aid=20360&group_id=9&atid=498

michael williamson (michaelw) added a comment.Via Old WorldJul 1 2010, 9:01 AM

Confirmed in ubuntu linux 10.04 64bit as well...default wacom driver from the repos...
(wacom intuos 3 and wacom intuos 4)

I found it very noticable when I cranked up the strength in the "sculpt branch" a few builds ago when the strength was stronger than it is now...

can't be a driver thing!

Mike Erwin (merwin) added a comment.Via Old WorldJul 3 2010, 1:09 AM

I have found what's causing this problem, and will fix during the summer of code -- most likely by the end of July. You're right, it's not a driver (or platform) issue; it's the way pressure and other tablet data is passed from ghost to the window manager. Since this requires significant changes, the fix will only apply to 2.5+.

Brecht Van Lommel (brecht) added a comment.Via Old WorldJul 21 2010, 5:31 PM

Duplicate report closed:
http://projects.blender.org/tracker/index.php?func=detail&aid=19660&group_id=9&atid=498

Tom Musgrove (letterrip) added a comment.Via Old WorldJul 22 2010, 11:19 AM

Mike Erwin, can you provide additional detail of what the fix would be?

Mike Erwin (merwin) added a comment.Via Old WorldJul 22 2010, 11:41 AM

Soitenly. Mentor Ebb and I discussed this just days ago.

Currently there's a gap between ghost and the window manager regarding tablet-specific info. Cursor events and tablet info (pressure, tilt, etc.) arrive at the window manager via different routes, then are recombined into the higher-level events received by the tools. The fix is to eliminate this gap by attaching tablet info directly to cursor events immediately when captured from the OS/driver.

In addition to (hopefully) fixing this bug, this approach will more faithfully capture what the pen is doing.

Thomas Brandt (the_last_rookie) added a comment.Via Old WorldJul 28 2010, 7:43 PM

I found the same bug in blender 2.5

(Ubuntu 9.10 - Karmic Koala 64Bit)
with my WACOM Graphire 4 Tablet.

I got no pressure sensitivity in blender 2.5 alpha and beta.

On the same system i have no trouble With blender 2.49 and Gimp.

Thomas Brandt (the_last_rookie) added a comment.Via Old WorldJul 28 2010, 7:45 PM

I must correct my statement:

i do not have the same error, i got no pressure sensitivity at all.

Best regards

Matias Ferrini (oberonking) added a comment.Via Old WorldAug 13 2010, 4:44 PM

I'm still have the same issue in 2.53 r31305...
I'm using Ubuntu 10.04, wizardpen driver.
My tablet is a Genius G-pen F509, In Gimp, mypaint, XaraLX, inkscape, alchemy the pressure works smoothly.
On blender work only the first time that I open blender after turn on the PC... after that loose every pressure.

Ton Roosendaal (ton) added a comment.Via Old WorldNov 20 2010, 5:44 PM

Mike: are you still around for this?

Mike Erwin (merwin) added a comment.Via Old WorldNov 22 2010, 5:36 PM

Yes, in a way. I've been schooling instead of blending, and will be available for full-on hacking the second week of December. There are lots of tablet revisions in my soc branch, so I'd like to hold onto this bug until it's fixed.

Ton Roosendaal (ton) added a comment.Via Old WorldDec 15 2010, 11:43 AM

Hi Mike,

It's halfway december already! I'm kicking the oldest reports here now.

Matias Ferrini (oberonking) added a comment.Via Old WorldDec 15 2010, 2:01 PM

Hi, I Still have this issue... I build blender today (r33683) and the same: the pressure works only when I start blender for the first time, if I closes it and re open the pressure are gone.
Mi tablet: Genius Gpen F509
OS: Linux Mint 10 (Ubuntu 10.10 based)
Tablet Driver: xserver-xorg-input-wizardpen 0.7.4-3maverick0
lsusb: Bus 002 Device 003: ID 172f:0038 Waltop International Corp. Genius G-Pen F509
xinput -list:
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Genius Optical Mouse id=8 [slave pointer (2)]
⎜ ↳ WALTOP Tablet id=9 [slave pointer (2)]


Works fine in all the apps (gimp, mypaint, etc)... In the past, in xorg, change the device to "Stylus" Blender take the tablet and pressure work. Now xorg don't change anymore the device option.
In Windows my tablet works fine on Blender..

Ton Roosendaal (ton) added a comment.Via Old WorldJun 19 2011, 12:49 PM

Mike has replied to other reports that he will work further on tablet issues after siggraph (in august).
I will summarize this case in the todo in wiki and will remind erwin to verify it then.

http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Install-OS#Tablet_.26_pens

Sergey Sharybin (sergey) added a comment.Via Old WorldApr 3 2012, 2:52 PM

Is there some progress about this issue?

Mike Erwin (merwin) added a comment.Via Old WorldApr 26 2012, 6:31 PM

I've got a fix ready, but it's a large (disruptive) change. Waiting until after the BMesh release. Should clear up this issue on all platforms.

Thomas Dinges (dingto) added a comment.Via Old WorldJun 11 2012, 12:19 AM

Mike, any updates on this?

Thomas Dinges (dingto) added a comment.Via Old WorldSep 28 2012, 10:59 AM

Mike? If you can't work on it, assign to someone else please...

@Spencer, recently I've made some changes and fixes to pressure handling,

Could you confirm if this is fixed in r54000 or newer.

See: Tablet Fixes/Improvements
http://wiki.blender.org/index.php/User:Ideasman42/WhatImWorkingOn#Week_127_.28January_7th.29

Ton Roosendaal (ton) added a comment.Via Old WorldFeb 16 2013, 3:26 PM

Spencer hasn't replied here in 3 years, time to close this.

Ton Roosendaal (ton) closed this task as "Resolved".Via Old WorldFeb 16 2013, 3:26 PM

Add Comment