Page MenuHome

Cannot quit application
Closed, InvalidPublic

Description

Problem with latest version 2.5


When I open blender ... and do nothing for more than about 10 seconds my processor load runs to 50% and stays there ( fully load after 5 mins ) (one processor in a two processor system ). Previous versions return to more or less idle after in brief burst of activity.

When I try and then quit ... without any other activity!! nothing happens
( the application never response and must be killed from a command prompt )

I am a programmer and and prepared to build 'debug' build etc to help resolve this ... even do some probing if someone could outline likely problem areas.


Revision 2.5 Alpha 2
Revision 27245
External revison 441
Ubuntu 9.10 - the Karmic Koala - released in October 2009
Kernel: linux 2.6.31-19-generic

Hardware 2.4 GB
Intel dual Pentuim(R) 3.2GHz


Details

Type
Bug

Event Timeline

I believe that could be connected with sound (SDL or OpenAL) in Blender. I had similar issues (couldn't quit Blender or Blender hangs) but its gone after set sound engine to none (in User settings panel) and save as default settings (Ctrl+U)

Thanks Michal

Can confirm problem is with sound module as when I set the sound to none half the problem disappears.

Suggest that it is a problem with old configuration files as when I re-enable the sound as suggested by Michal Mielczynski the processor becomes heavily loaded but now quit works.

ie one half of the bug report is now cleared

Note when sound is re-enabled 4 copies of the following message appear on the console.

bt_audio_service_open: connect() failed: Connection refused (111)

Duplicate of:

https://projects.blender.org/tracker/index.php?func=detail&aid=19868&group_id=9&atid=498

and

https://projects.blender.org/tracker/index.php?func=detail&aid=20466&group_id=9&atid=498

See my last comments there and file a bug report to your distro...

Joerg Mueller (nexyon) closed this task as Invalid.Mar 5 2010, 8:21 AM