Home

Scene strip preview not working
Closed, InvalidPublic

Description
Content placed on the timeline does not show up in the preview window. The preview window just appears black with a scene loaded and appears as a white rectangle with an image loaded.

This can be seen by opening blender and adding the default scene as a strip in the sequencer, hence I have not uploaded a .blend file.

r28290 winXP 32bit
mingw +scons - no optimizations
loopduplicate (loop duplicate) set Type to Bug.Via Old WorldApr 19 2010, 11:29 PM
loopduplicate (loop duplicate) added a comment.Via Old WorldApr 19 2010, 11:32 PM
sorry, this bug only shows up on my laptop with an on board Intel video card. So it might just be a limitation of my hardware. It works fine on my desktop pc with an nVidia card.
loopduplicate (loop duplicate) added a comment.Via Old WorldApr 19 2010, 11:46 PM
But then again, it works on 2.49 with the laptop just fine.
brecht (Brecht Van Lommel) added a comment.Via Old WorldApr 20 2010, 11:33 AM
Please do include a .blend file and a screenshot, to ensure we are talking about the same window setup, there were some problems with the sequencer preview in existing .blend files if I remember correctly.
I'm attaching the .blend and a screenshot.
Here's the .blend, a screenshot, and a dump from CPUZ of my system specs.
loopduplicate (loop duplicate) added a comment.Via Old WorldApr 20 2010, 7:47 PM
Bad internet problems caused me to send the attachments twice on accident so disregard the two files that are doubles, they are exactly the same. Damn internet tubes!
broken (Matt Ebb) added a comment.Via Old WorldApr 21 2010, 5:13 AM
Well, I don't get the bug demonstrated in the screenshot, but I do notice some dodgy business going on if I change a render setting (eg. world colour) and then try to go to a new frame - blender will crash in somewhat random places. Perhaps threading issues?

Assigning to Peter
calli (Carsten) added a comment.Via Old WorldApr 21 2010, 2:31 PM
@loop duplicate: Try to delete your preference .B.blend file, for me it solved the issue that the sequencer preview was not shown.
loopduplicate (loop duplicate) added a comment.Via Old WorldApr 30 2010, 3:21 AM
@Carsten
I delete the entire installation and build folders before I build blender from svn on a daily basis. This bug happens even when I run Blender for the first time on a fresh install with no modifications to the preferences.

"""""
Sender: Carsten

@loop duplicate: Try to delete your preference .B.blend file,
for me it solved the issue that the sequencer preview was not
shown.
"""""
a_saurus1 (A Saurus1) added a comment.Via Old WorldMay 14 2010, 5:22 PM
This is happening to me too, on all builds that I've tried so far. Really annoying, since I'd like to use the sequencer. Does it have anything to do with the fact that GSGL doesn't work on my computer either?
a_saurus1 (A Saurus1) added a comment.Via Old WorldMay 19 2010, 1:20 AM
Just wanted to also note that this worked for me in blender 2.4x. And in 2.5, it does not work (the white rectangle appears) regardless of my graphics acceleration settings, or the blender window draw mode setting. My graphics card is an ATI RADEON XPRESS 200, 704 Mb RAM. From what I've gathered, the problem doesn't happen with nVidia cards, so it's other cards (like ATI or Intel) that are problematic.
blendercomp (Ilias Karasavvidis) added a comment.Via Old WorldJun 8 2010, 3:41 PM
I confirm the problem on WinXP Professional SP3, with the latest intel video driver installed:
http://img411.imageshack.us/img411/424/blenderscreenshot.png

I could replicate the error with all svn versions I've checked. 2.4x works fine though.
loopduplicate (loop duplicate) added a comment.Via Old WorldJul 13 2010, 4:54 PM
When using the same laptop, I get different results on different operating systems.

This bug occurs on Windows XP 32 bit and Windows Vista 32 bit but doesn't occur on Ubuntu 10.04 64 bit.
loopduplicate (loop duplicate) added a comment.Via Old WorldJul 30 2010, 9:08 PM
Another note: this bug happens to me no matter if Blender is compiled with MSVC and CMAKE or GCC and scons. It also happens with other people's builds. It also happens with the official blender.org Beta.

The preview window in the VSE is always a white square for any strips added. In other words, video strips and scene strips do not work. So I cannot use blender's VSE at all. Every time I see the VSE in a Durian blog I get sad because I can't do that.
Some graphics cards / drivers cant render from an opengl offscreen buffer.
can you try render the 3d viewport, does this work? - this code is shared with the sequencer.
a_saurus1 (A Saurus1) added a comment.Via Old WorldSep 17 2010, 2:46 AM
Aha! I got an error message saying "Failed to Create Offscreen OpenGL buffer" That seems to be the problem. Can you guys put in an option to draw the preview the way it was in 2.49? That method seemed to work for me.
nrk (Nick Keeline) added a comment.Via Old WorldOct 22 2010, 6:00 AM
We have an entire blender artists thread for this bug lots of juicy extras about it with screen shots etc:

http://blenderartists.org/forum/showthread.php?t=195541&page=2
hanaishi (Pierantonio Pozzan) added a comment.Via Old WorldOct 22 2010, 6:34 PM
I confirm this bug too: the preview is a white rectangle, doesn't matter what the strip is (an image, a movie, a color).
My configuration is:
OS: Ubuntu 10.10 64 bit (but already with 10.04 64 bit)
GPU: ATI Radeon X1900XT
Driver: radeon (from the repo)
Blender: at least from blender 2.53 to 2.54 svn
trock (Terry Rock) added a comment.Via Old WorldNov 8 2010, 3:30 AM
Version 2.55 seems to still have the problem. Any ideas on when a fix may be in the works?
a_saurus1 (A Saurus1) added a comment.Via Old WorldNov 11 2010, 11:58 AM
@terry

Unfortunately, I think they don't have it on top priority, because it works for all but a few of us. I did add a section to the todo list about adding an option to allow the sequencer to render using the 2.49 method (without the offscreen buffer), but I don't know when that will get looked at.
annami (Andre Lewis) added a comment.Via Old WorldNov 15 2010, 1:43 PM
I have this behavior as well, I think it has to do with the video card drivers however. It appears in the latest build 33084 gentoo linux x86, using an Nvidia GeForce 4 MX card. On my other machines it works fine.
jhk (Janne Karhu) added a comment.Via Old WorldNov 16 2010, 7:47 PM
Please check if changing the render resolution to a power of two (for example 512x512) "fixes" the problem. If so then this is a know issue, and can be closed as a duplicate of #24656.
a_saurus1 (A Saurus1) added a comment.Via Old WorldNov 24 2010, 3:49 PM
@Janne
But #24656 was closed as a duplicate of this...
loopduplicate (loop duplicate) added a comment.Via Old WorldNov 29 2010, 7:50 AM
I tried again today to reproduce this bug and to try the tests Campbell and Janne suggested.

On Ubuntu 10.10 64bit everything works nicely.
On Windows XP 32bit the bug is still there.

I can't render the 3d viewport with OpenGL because of the "failed to create OpenGL offscreen buffer" error.

The problem is "fixed" by setting the render resolution to 512x512.
a_saurus1 (A Saurus1) added a comment.Via Old WorldDec 1 2010, 2:28 PM
Ditto what LoopDuplicate said, it works on my windows 7 machine but not on my older XP machine with an ATI Xpress Chipset. And I've updated my drivers, so that's not the problem.

Also, I noticed that if I set the res to 512x512, it shows the image properly, but if I try to do something like add a glow or a cross fade to a clip, or to display a scene strip, it either shows a white screen (in the case of the scene strip), or it shows the highest channel image under the cursor, but without any effects. So if I have an image on channel 1 and 3, and a cross fade between them, putting the cursor over the cross fade shows the image in channel 3, but it doesn't cross with the channel 1 image.
ton (Ton Roosendaal) added a comment.Via Old WorldDec 7 2010, 7:43 PM
The 2.4x method was just doing a full render, which caused you to wait for the entire render cycle to finish. That's not very useful either.
The best thing I can think of is to add a warning in Blender when off-screen buffers fail... but that can also be annoying. Maybe draw a stamp-text in the buffer? That would give more info. :)

The issue has been added to our todo for later investigation.
http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Editors#Video_Sequencer
Thanks for all the feedback!
ton (Ton Roosendaal) closed this task as "Invalid".Via Old WorldDec 7 2010, 7:43 PM
geleto (Angel Popov) added a comment.Via Old WorldFeb 2 2012, 12:24 AM
I've experienced a similar bug (white rectangle when size is not a power of two) before in other software that I am developing.

This bug happens on some Intel GPUs, and on old ATI/NVidia hardware.
While newer ATI and NVidia hardware will happily render a non-power-of-2 textures, some Intel and some drivers for old ATI/NVidia hardware will render everything white.

To avoid this, do these steps:
1. check if the GL_ARB_texture_non_power_of_two extension is present, if so - everything is ok and you can safely use non-power of 2 textures
else
2. check if the GL_TEXTURE_RECTANGLE_ARB extension is present, if so - use it. Pay attention to the fact that texture coordinates lie in a [0..w]x[0..h] range and mipmap filtering is not allowed.
else
3. Expand the texture size to the closest power of 2

Why is this bug closed?

Add Comment