Page MenuHome

No Vertex Parent on Scene Start
Closed, ArchivedPublic

Description

Category: Conversion

Hi.
Here is a ugly Bug on BGE Scene start. Vertex Parents does not work from Startup.
Have a look at the File. Thank You.

Details

Type
Bug

Event Timeline

Oops, vorgotten:

Noticed in Blender 2.49b 32/64 and 2.5

Win7 64; ATI 4850; Catalyst 10.3

confirmed. two things happening here:
(1) parenting not taking into account at start time when the parent type is vert
(2) vertex parenting not working at all.

@Doc: does vertex parenting ever worked in BGE? It seems to me like the kind of feature supported in Blender only. So to fix (1) is simple, but (2) is probably hard.

Hi. Sure! The GE can handle Vertex Parent as long i can think of. It is a essencial Tool to eliminate rotations from a Parent/Child relationship. And easy to use, too. I used it a lot.

Try the File with older Blender Versions, and you'll see. ;)

Workaround is to Clear Parent and Keep Transformation, then Vertex Parent again.

Hello to all.
I parent object to verticle of another object. Than I select relative object, alt+p > clear parent inverse.
Than I write it's local coordinates.

The parenting to verticle works well in 3d view in object mode.
But when I press P (switch to game mode), the vertex parenting is still working, but it consider the origin point (or the lower point of object, I don't know) as it's vertex parent.

Aaron Carlisle (Blendify) closed this task as Archived.
Aaron Carlisle (Blendify) claimed this task.

This task is being closed because the BGE has been removed in Blender 2.8.