Page MenuHome

Blender creates ".thumbnails" folder in Windows user folder root
Closed, InvalidPublic

Description

When you install the Blender 2.53 beta on Windows, it creates a ".thumbnails" folder in the user's home directory. This is the Unix-style method for hidden folders, and shouldn't be used in Windows. Blender should instead use some subdirectory of "AppData\Roaming\Blender Foundation\Blender", since it already creates this folder anyway.

At the very least, if the folder must be created here, it should be tagged as "Hidden" under Windws instead of just relying on the period prefix notation.

I noticed this installing Blender 2.53.0 r'30581', x64 package, on Windows 7 Ultimate x64.

Details

Type
Bug

Event Timeline

Hi,

Andrea, can you take a look at this ? there is any motive to keep the same folder name on Windows ?

Thanks,

- Diego

Hi,

yes, there is a motive and reason behind using this folder for thumbnails.

It follows the Thumbnail managing standard (http://jens.triq.net/thumbnail-spec-0.3/index.html) shared by many open source programs (Gimp for example)
This means that for users who have Gimp installed, it will use the same folder for thumbnails and not use up duplicate space by just using our own directory.

If other open source programs move this folder to a more Windows specific location, we will align with their approach but until then this is by purpose.

Closing the report since this is not a bug.

Andrea Weikert (elubie) closed this task as Invalid.Aug 9 2010, 9:08 PM

Interesting. I've sent the author of that spec an email, to see what his intentions were on Windows systems. Suspect it just didn't come up.

IMHO, if this to be shared between various apps, it should still be located as "AppData\Local\.thumbnails" (or "Application Data\Local Settings\.thumbnails" for XP and previous) on Windows systems. Unfortunately a trend seems to have started for treating the root of the user's folder in this way, when the intention is to keep application data & settings in "AppData".

Users can configure the Start menu to display the user root as a folder, which then starts getting bloated with these extra items when you just want to see your documents, videos, music, contacts folders etc. Perforce is another offender... that's why I suggested creating the folder as "hidden", which removes it from such a view; surely the intention of using the period anyway.

Do you have any more info about the reasoning behind this? That link is dead and no longer works


It follows the Thumbnail managing standard (http://jens.triq.net/thumbnail-spec-0.3/index.html) shared by many open source programs (Gimp for example)

On Windows the %HOME% environmental variable (where %HOME% = %HOMEDRIVE%%HOMEPATH%) is not the same as the %USERPROFILE% environment variable which usually points to C:\Users\%USERNAME% which is the root user folder. Since the %HOME% variable can be set differently, I think blender and other programs should use the %USERPROFILE% variable instead of the %HOME% variable by default on Windows.

Is there a way to change the default .thumbnails directory location?

You're right, the link has been removed, it's now here: (updated version as well)
Thumbnail Managing Standard

As far as I checked, we're not using the %HOME% environment variable, but actually the CSIDL_PROFILE path, which corresponds to the %USERPROFILE% environment variable.

You can't change the default path, since other programs use the same path, and this means that for example thumbnails created by Gimp are also used by Blender and vice versa.