Page MenuHome

Image too small Error
Closed, InvalidPublic

Description

Hey Fellas, r31878 win xp nvid 9600gt

I was able to grab a screen shot of the Image too small freeze while I was in the process of rendering a smoke test. The error keeps repeating for me as I add a material and texture to the domain cube. thanks again

Event Timeline

Closed duplicate http://projects.blender.org/tracker/index.php?func=detail&aid=23845&group_id=9&atid=498

Hrm, I'm unable to check this. Doing anything with it results in a run-time check failure: stack around the variable 'out_len' was corrupted in pointcache.c (line 670 on bake or 807) on reopening after first failure). Assigning to Janne for further checking.

I did get the error one time, but now I can't reproduce it however much I try. Adding a volume material and volume data texture goes fine for me, although the texture preview shows nothing most of the time. Rendering doesn't give any errors either (except that the smoke is tilted 90 degrees since the domain cube is rotated).

I also couldn't reproduce the run-time check failure that Nathan got at all.

It seem that turning off the compositing and sequencer pipelines, when not in use has cut down on the number of freezes drastically. At times it was getting so bad I would have to add an object or material-save-then-render-freeze-restart and repeat.


thanks again

Potential duplicate: https://projects.blender.org/tracker/index.php?func=detail&aid=23843&group_id=9&atid=498

Howdy Folks,

Ok I am including a blend file called "cube"
I have been able to recreate the image to small error on demand now.

Open the file
add a diffuse color
render
close the "render in new window" image by clicking x-icon upper right hand corner-it should now freeze.
If you do no get the "image too small error" repeat render-close untill you do "sometimes it takes a few times"
reopen the cube file
add diffuse color
then jump to render panel
under dimensions you will see that its set
to "render presets"
change it to whatever resolution you want
then render and that seems to resolve the freeze issue
"image to small"

so it seems it doesn't like to render with a material when the render preset dropdown is set at "render presets"

also sorry I was wrong about it being the compositor-sequencer issue


thanks again

Right, I can now redo. Thanks for finding out! Time to set breakpoints and figure out what really is going on :) Reassigning to myself for now.

Closed duplicate of https://projects.blender.org/tracker/?func=detail&aid=23600&group_id=9&atid=498

Thanks for the recreation steps. A temporary fix is now committed! The real reason is probably somewhere deep in the window manager code, which still has a lot of problems with stuff, so I'm closing the report and adding this as a reference link to the todo-list.

Janne Karhu (jhk) changed the task status from Unknown Status to Invalid.Sep 21 2010, 4:44 PM

Going through old UI ToDo tasks - this looks like a GPU context switching issue, which was entirely reworked during 2.8. So I think this was fixed by now, so marking the ToDo item as done.