Page MenuHome

drivers not updating correctly with certain target channels
Closed, InvalidPublic

Description

Hi there,

there seems to be a lack of update with certain driver target channels.

To reproduce:
(1) add single driver on default cube's x location
(2) in graph editor change from FCurve-Editor to Drivers
(3) select XLocation and inspect the driver in N-Property-Panel
(4) remove all modifiers and set driver to SUMVALUES
(5) add a variable (Single Property)
(6) set it to Prop:Scene, 'Scene', and put the data_path to 'frame_current'

this will update once when you hit enter but no more when you change frames

actually I didnt have luck with any type other than Prop:Object ...


I also tried
Prop:World, data_path:'ambient_color[1]'
Prop:Camera, data_path:'lens'
Prop:Material, data_path:'diffuse_intensity'

Greetz
Philipp


(this is on rev.32876 btw.)

Details

Type
Bug

Event Timeline

ubuntu 10.04 64bits rev32908

It is a lack of update for modifiers, here.
Only viewport is not updated.
Drivers don't work at all for some datablocks Materials, Textures, World, Scene.

It works for Camera,Object,Mesh,Lamp.

I think that problem with camera Lens is probably due to ability to express it by focal length or Angle.

This is a known issue. Currently the dependency graph only supports object properties as target variables, so any other targets are not updated properly. Closing the report and adding as it an additional reference to the todo-list entry.

Janne Karhu (jhk) closed this task as Invalid.Nov 8 2010, 10:45 AM

maybe the 'non-valid' target variables should be disabled/taken out of the enum, then? [as much as I hope they are back soon :)]