Page MenuHome

startup error msg about ALSA when JACK active
Closed, InvalidPublic

Description

I just downloaded blender-2.56a-beta-linux-glibc27-x86_64.tar.bz2 on my openSuse 11.3 (64) / Intel i7 system.
On start-up (started from the command line in the directory where it was unpacked) the next error messages about ALSA appeared in the console :
----
frans@SpinL2> ./blender
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
AL lib: alsa.c:344: Could not open playback device 'default': Device or resource busy
AL lib: oss.c:179: Could not open /dev/dsp: Device or resource busy
found bundled python: /home/frans/3d-projects/Bender-2.5beta/2.56/python
*bpy stats* - tot exec: 30298, tot run: 0.9336sec, average run: 0.000031sec, tot usage 0.8069%
Saved session recovery to /tmp/quit.blend

Blender quit
---

In above session I quit Blender almost immediately, but it seemed to be working normally.
This looks fatal for audio i/o, though i did not test anything.

On my system most of the time JACK is active for working with midi keyboard and midi/audio applications.
After the JACK process (jackd) was stopped, Blender started without these error messages.

Blender 2.49b (was already installed from the openSuse repository) does not complain when Jack is active, but I have never tried any audio in Blender
.
Not all software can work with audio when Jack is active; a nasty one (do a google search) is a media player plug-in of Firefox, which tends to lock up the audio completely and I need to kill these processes before Jack can be started (stopping Firefox is not enough).
These same apps might prevent Blender from using the audio too !

I am new to Blender (starting with my first game engine app, involves midi file and real-time input), but I can help with more information or testing, just ask me.
n.b. my system only has the on-board integrated audio.

Details

Type
Bug

Event Timeline

This error message comes from OpenAL, because OpenAL is the default audio backend in blender and when blender tries to open OpenAL it prints that error message. No way supress it, but the initialisation of OpenAL fails and blender continues correctly without audio.

If you want to remove that message change the Audio backend in the user preferences to None. Or if you want to use Blender with Audio and Jack you an even choose blender to use Jack!

Closing.

Joerg Mueller (nexyon) closed this task as Invalid.Jan 10 2011, 1:09 PM