Page MenuHome

Video Sequencer: F-curve insertion failure after un-meta
Closed, ResolvedPublic

Description

Fault: Cannot mix audio, as F-curve fails.

I have added movie strips to the (Master) timeline then cut and copy/pasted pieces into the correct order, from another (Source) scene's timeline.

One audio clip, the first one to have an F-Curve applied, will attenuate correctly. But subsequent F-Curves are not applied when inserting a keyframe in the Strip properties window.
They get an error;
"Could not Insert keyframe, as RNA path is invalid for the given ID..." see attached jpeg.

B2.56a Trunk r34541
win XP
ser pk 3

intel xeon CPU 5140@2.33Ghz
3GB ram

Details

Type
Bug

Event Timeline

The error should have been caused by the copy/paste then. How did you precisely do this?

I am performing an edit based on these instructions
http://blendervse.wordpress.com/2010/10/20/vse-an-editors-layout/

I make a .blend with multiple scenes.
1. Master edit scene
2-n. Camera shot scenes

I cut (K-key) the desired portion of a camera strip from the "Camera shot scenes", then copy that portion to the clip board.

Then I goto the "Master edit scene" and Paste that portion of the Camera strip onto the timeline.

Then I try to keyframe the volume/attenuation.

Both shots were pasted in this way but only one failed (the one on the right).

David: you say "cut a camera strip" that means "cut an audio strip in the camera shot scene" right?

How does this relate to the .blend file you attached? If add a new scene there, and copy the cut audio strip from first to new scene, the copy went fine (without the animations though).

yes I meant the audio strip that was imported with the video (camera) strip.
After reading this I tried adding f-curve in other scenes strips and they did work.

I then copied/pasted the faulty audio strip in the same scene and this made it work again.

The broken audio strip //XXEdit footage\Swap footage\MVI_3928.mov in the .blend won't acept any keyframes until copied and replaced.

It seems that it has been corrupted after I Meta the audio strip AND the associated video strip together (so they are locked in sync for moving on the timeline), then Un-Meta the strip.

after Un-meta-ing the strip I have that error when inserting a keyframe.

Changed report title, maybe we attract someone to fix it then. :)

Possibly related Fault:

Using Blender 2.56.2 SVN r35375 I have recently noticed that audio becomes MUTE after performing a copy->paste of an audio strip.

When cached the waveform remains, and the original strip will play ok. But the copy (even in the same scene/timeline) will not playback audio.

It can be restored by "Save/close/re-opening" the .blend.


F-curve Bug workaround:

I have found that if I add a keyframe(KF) to each strip (just one dummy KF) in the "Source Scene timeline", the keyframes will work once the strip is copied into the "Master Scene timeline".

This was a very good bug, thanks for the report! The problem was that copy/paste of meta strips didn't create scene wide unique names for the copied/pasted strips, so when the strips were pasted they had the same name. This created a problem as f-curves use the strip names to identify which strip they belong to, so having non-unique names resulted in non-keyable strips.

I committed a fix in r35778, so this problem shouldn't happen anymore. This won't fix the example blend directly as the names have already been set as identical, but you can make the strips keyable by simply renaming the strips manually so that each strip has a unique name.

If you still experience the other bug you mentioned after this fix please open a new report for that!

Janne Karhu (jhk) closed this task as Resolved.Mar 25 2011, 12:50 PM

This fault occurred again in a recent build.
That is an overlap between 2 trimmed meta strips (that have audio in them) allowed bleed through from the next strip.

So when strip 1 is playing, strip 2 begins early. Even with audio keyframes that should make strip 2 quiet.

win 32bit r41259