Sculpt Mode hotkeys exhibiting strange behaviour and default brush hotkeys missing/broken
Closed, ArchivedPublic

Description

Build: Blender 2.56a SVN r34736 Win32

Confirmed with other users on irc#blender

Standard sculpt keys have not been implemented as per documentation.

Toggle Airbrush (A) exhibits strange behaviour ... resets stroke mode to <empty/null> instead of returning to previous stroke mode. Random behaviour when starting from other modes.

Toggle Add/Subtract (V) is toggling to/from Vertex Paint mode.

Draw (D) non-functional
Grab (G) not-functional
...
Other default hotkeys are non-functional (see http://wiki.blender.org/index.php/Doc:Manual/Modeling/Meshes/Sculpting for full list of hotkeys).
...
Constraints (X/Y) non-functional
Contraint (Z) functional but switches to wireframe (not overly helpful in sculpt mode).

I apologize in advance if this is already on the TODO's or other bug reports, I tried my best to find any mention of it, it did track down a video on custom hotkeys, however the standard ones don't appear to be set and the brush panel has changes significantly since. http://vimeo.com/8557229

Many thanks in advance, I appreciate the hard work that goes into blender.

Kindest regards.

jiggles100 (Giles Bayliss) set Type to To Do.Via Old WorldFeb 10 2011, 9:21 PM
sergey (Sergey Sharybin) added a comment.Via Old WorldFeb 10 2011, 9:45 PM

I'm afraid there's no much we could make here. Documentation you're pointing at is written for Blender 2.49 and sculpting tools were fully re-designed since that time. Now you could have several grab brushes, several draw brushes and so on.It's unclear for how G/D keys should work in this case. You could use number 0-9 and Shift 0-9 to toggle between first 20 brushes.
Add/subtract could be toggled with Ctrl key (per-stroke toggling), no "global" add/subtract toggle still.

The only thing I could help -- fix problem with A-key. All the rest things seems more a TODO. Added not to our TODO wiki (http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Tools#Sculpting) and A-key issue to my own TODO list.

Thanks for report, but it couldn't be treated as bug report, so closing with todo resolution.

sergey (Sergey Sharybin) closed this task as "Archived".Via Old WorldFeb 10 2011, 9:45 PM

Add Comment