Page MenuHome

subdivide UVs option of subsurf modifier exposes seams
Closed, ArchivedPublic

Description

When using subdivision surface modifier on a mesh, to avoid distortion of the textures the option "Subdivide UVs" should be checked. This way the inside of the texture gets smoothed and is O.K.
But this introduces another problem - the UVs are fully smoothed, including the edges (the island borders), which leads to "cracking" and another artifacts on seams, in effect actually revealing them. This is a problem regardless of the way the texture is prepared - painted in external program, or in Blender itself.

I expect the subdivision modifier to smooth the UVs without moving the edges that are marked as seams. This way I can paint precisely and hide the seams easily, because I will be sure that they will stay on exactly the same pixels on the image. I use the "snap to pixels" option of course (but that doesn't relate to the problem).

This problem affects all known to me versions of Blender. In particular I use the 2.56.2 r35374M svn revision, built on a 64 bit Gentoo Linux.

I regard this as a bug, because it directly interferes with the possibility to create and render precise textures in Blender.

Details

Type
To Do

Event Timeline

We have added seams as a way to do UV unwrapping. The modifiers have no knowledge of it.

It's a good feature to add yes, I've noted it here:
http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Tools#Subdivision_Surface_Modifier

We do stick to a strict bug definition here though: "when it was intended to work but fails". otherwise this tracker turns into a huge feature request listing...

Ton Roosendaal (ton) closed this task as Archived.Mar 9 2011, 3:18 PM

Thanks for answering Ton!

I didn't knew the modifiers doesn't know about seams, so I thought this is a real bug. Sorry for reporting it here.

And I am glad to see this on the todo list, thank you!

Petar