Page MenuHome

Indirectly linked shrinkwrap fails
Closed, ArchivedPublic

Description

The files attached show an error with linking and the shrink wrap modifier.
(found this when looking into another linking bug)

a.blend == a mesh to apply shrink wrap too
b.blend == links in mesh from a.blend and uses as shrink wrap target
c.blend == links in b.blend's shrink wrap target and modified mesh

in c.blend the modifier is not applied when it should be.

Details

Type
To Do

Event Timeline

note, this works on first linking but fails on reload.

found the cause
- the object in a.blend in linked into c.blend via b.blend and directly
- the object is actually in memory twice. (checked the pointers)
- in the scene the object is directly linked and from the modifier indirectly.
- the one in the scene has a derivedFinal pointer but not the one the modifier refers to.

so the real fix is to not have these objects linked twice.

Does "not have this objects linked twice" mean if somebody linked objects in such way some artifacts might happen or it means linking stuff should determine such indirect linkage and add only one object in memory?

the object is loaded twice - as in its in memory twice.

To me it seems to be design issue; that using both a direct and indirect ID pointer hasn't been meant to work anyway.

Why not mark this issue on the todo for "issues with library system" and make it a target to work for ehh Blender 3.0 once ;)

Collecting library linking issues in the wiki:
http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Import_Export

Ton Roosendaal (ton) closed this task as Archived.Nov 2 2012, 12:43 PM