Page MenuHome

Objects not updated as they become visible in layers
Closed, InvalidPublic

Description

I'm trying to find a serious bug (but too complex all at once) with point caches / smoke / shared actions and between scene links that causes animation to offset.

The effect of this bug is offsetted animation in some of the source object's

Since I don't know what is the culprit Ive prepared a simple blend with 3 objects:

all of them share the same action but are located in layer 1, 2 and 3

when frame changing with only one of the layers active and then selecting another layer you see how the object hasn't updated until you force a refresh

I suspect this has something to do with the bake all dynamics going nuts

Details

Type
Bug

Event Timeline

Didn't check the file... but I do know that layer switching currently tries to do conservative changes only, to prevent it being slow.
Frame changes do work fine.

Depsgraph issue? Maybe janne can give a real verdict here.

rev 40164

Problem seems to have been fixed.
Blend doesn't show lack of UI update.

It's not fully fixed yet, how to redo:
* enable only second layer
* move one frame forward
* enable only first layer

This is a dependency graph issue with objects not getting updated as they become visible in a layer. Problem is that update tags from editing or frame changes are only set on objects on visible layers. Closed a duplicate of this bug here:
http://projects.blender.org/tracker/index.php?func=detail&aid=27446&group_id=9&atid=498

Closed issue caused by exactly the same issue -- http://projects.blender.org/tracker/?func=detail&aid=30176&group_id=9&atid=498

Added to the dependency graph todo list:
http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Animation#Dependency_Graph

Ton Roosendaal (ton) closed this task as Invalid.Mar 21 2012, 4:57 PM