Page MenuHome

Tree Gen "Sapling"
Closed, ArchivedPublic

Description

Project: Blender Extensions
Tracker: Py Scripts Release
Blender: 2.64
Python: 3.2
Script name: Sapling
Homepage: http://blenderartists.org/forum/showthread.php?214857-Sapling-A-Tree-Generator-Add-On-for-Blender
Wiki page: http://wiki.blender.org/index.php/Extensions:2.5/Py/Scripts/Curve/Sapling_Tree
Author(s): Andrew Hale
Category: Curve
SVN Download: https://svn.blender.org/svnroot/bf-extensions/trunk/py/scripts/addons/add_curve_sapling/
Status: Open

This script uses the algorithm presented by Jason Weber and Joseph Penn in their paper 'Creation and Rendering of Realistic Trees' to generate parametric trees in Blender. Armatures (with or without animation) can be added to the tree as well as being able to save and load presets.

Event Timeline

hi, we need to upload an attatchment here. :)

Moved from Py Scripts Upload to Py Scripts Contrib

added andrew in bf-extensions devs, moving now to contrib and then adding a canned response

[canned response]

We gave you bf-extensions rights, read details at:

- http://wiki.blender.org/index.php/Dev:Py/Sharing
- http://wiki.blender.org/index.php/Dev:2.5/Py/Scripts/Guidelines/Addons

-----

* You can work on svn in contrib/ directory

See a help panel about svn here:
http://wiki.blender.org/index.php/Dev:Extensions/Sharing/SVN_Help

Don\'t forget to add a meaningful message at each svn commit

The password for svn is the same as the one you use to log in in this tracker.

* We invited you to our commits mailing list
see http://lists.blender.org/mailman/listinfo/bf-extensions-cvs

Please subscribe, so that your commit mail will be sent to
subscribers instead of hanging on
You should have received a mail already about it, if not,
please leave a line here, thx!

* Move your script in contrib/ directory in svn (if it\'s not
there already)

* We are assigning this script to yourself, so that you are
responsible for maintenance.

Please click on "Monitor" to receive updates when people edit
your extension tracker page

* Finally, we have moved this tracker page from the original
location in "Upload", so check the tracker_url field and commit
in bf-extensions

Thanks and welcome aboard! :)

Hi, i uploaded version 2.2,
I made some changes to the script registration to clean it up a little,
Also provided an attatchment of the working script.
Thanks & welcome Again. :)

Hi!
Since your script is now in bf-extensions\' svn (contrib|trunk) we have deleted the current attachments to avoid that end-users could reach this page and get the wrong version of your script.
Note that your script may have api changes or small maintenence changes applied in SVN.
Please retrieve your script from SVN before updating SVN to avoid mis-versioned scripts.
Thanks!

hi,
I've uploaded a zip file as it seems to be a problem that people cannot easily d/l the script.
Truman, you can update & link to the zip here & svn, that way users can have the best of both worlds. :)

Thanks for that, it's a bit more difficult now that I need a multiple script addon. Thanks again!

Moved from Py Scripts Contrib to Py Scripts Release

small bf extensions change.

Hi,
Due to changes to the api including the merging of bmesh, several addons are outdated.
Please, if you are the author of an addon check your script with blender revision 44256 or newer.
That is builds made After blender 2.62 official release.
I would ask that updates be made to your addon before the Blender 2.63 release.
6-8 weeks away.
This allows time for the api to become more exposed & bmesh to stablize furthur.
If you need help, drop into irc freenode #blenderpython or #blendercoders & feel welcome to ask questions.
At the time of 2.63 release, scripts that are not repaired or in active developement will have their tracker page marked "Closed"
this will not affect your links to the tracker, similar to closing scripts in 2.49b, the page will be still availible & can be re-opened.

Thanks for your understanding & patience during these Exciting Times.
Brendon.

Bug was reported in the tracker that leaves can be only hexagonal, not rectangular anymore after bmesh:
http://projects.blender.org/tracker/index.php?func=detail&aid=30765&group_id=9&atid=498

Thanks Brecht
It seems that rectangular leaf may conflicts with latest UVs? Is this the reason?

Thanks for the report, the problem was indeed caused by the new Bmesh system. I've disabled this part of the code and the commit is present in extensions r3275. I've tested and the script no longer breaks.
Cheers

@Andrew Hale
Blender build r46072
OSX 10.6.8

Now we have rectangular leaves again. But not of great use as no UVs exist on them.
Impossible to UV all these, of course.
(BTW, I tried to UV them, a terrible system crash happened. Even the mac beachball stopped... leading to another major bug report. A complain, this time. Not to you , of course not.

For reference, there is an open bug: http://projects.blender.org/tracker/index.php?func=detail&aid=35485&group_id=9&atid=498

I have found a bug where armatures are incorrectly placed in 2.68, see https://projects.blender.org/tracker/?func=detail&aid=37112&group_id=153&atid=469

There is also a bug where using "Armature Animation" does not make the actual curves follow the armature. (more details in the report linked above)

NEW BUG!!!
Hi, thank you for great script, very useful!

I found problem with user write permission on linux

I can't save preset, because dir /usr/share/blender/2.69/scripts/addons/add_curve_sapling/presets is only for root write permission.

Please fix this great script.

This task was automatically closed as archived as part of migration, because it was determined to be no longer active.

The authoritative list of addons is on the wiki, we no longer have a report for each addon to track bugs and updates. Bugs can be reported individually and assigned to the addon developers. See the Addons project page for more information on the workflow.

Nobody (None) closed this task as Archived.Apr 30 2011, 2:53 AM

It is possible to put the sapling settings on a panel that is not so easy to lose sight of.
If I had uvs or textures I would use it for a project in production.