Linked cloth sim object have a different position between viewport and render window
Closed, ArchivedPublic

Description

Step to reproduce:
File 1:
create a simple mesh with cloth modifier
create mesh with collision modifier
make it in one group
save

File 2:
file>link a group from file 1
move a linked group
render

ton (Ton Roosendaal) added a comment.Via Old WorldMay 10 2011, 7:01 PM

Campbell: we used for sintel linked meshes with sims too?

yep, this worked for durian and didnt rely on any render branch hacks IIRC. looks like a regression.

ubuntu 11.04 rev36825

Create a group instance in File 1.
Cloth of instance is rendered at same place.

Problem is the same for softbodies. (attach a .blend)

Fluid and Smoke have no problem with group instance.
Maybe because these effects can point to another external cache.



Double checked and from what I can tell this never worked in blender, at least the render branch also has the problem.

The difference between durian and this is that for durian the baked pointcache was written from the final scene in worldspace, so this rendered correctly.

This is different because the cache is from another scene and then relocated.
But still a bug ofcourse.

ton (Ton Roosendaal) added a comment.Via Old WorldOct 21 2012, 2:40 PM

Here's another animation system & dependency issue for the todo. All reports will get listed and used as a reference for specifications of new depsgraph code. I also want pointcaches to be solved for it.

http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Animation#Dependency_Graph

ton (Ton Roosendaal) closed this task as "Archived".Via Old WorldOct 21 2012, 2:40 PM

Add Comment