Transform bug when transform > 500
Closed, InvalidPublic

Description

When moving an object in 3D space using "G" for grab, and the distance moves beyond 500 (or -500 if in the negative direction) the transform value jumps to 999999552.00

This in using the official Win32 build r36339 on XP. Haven't had a change to test this with a Linux build yet.

Reuben Martin (fishb8) set Type to Bug.Via Old WorldMay 11 2011, 12:32 AM
ronan ducluzeau (zeauro) added a comment.Via Old WorldMay 11 2011, 11:39 AM

ubuntu 11.04 64 bits rev 36592

Reproduced.
Jump happens at a different value if after a zoom in or zoom out.

Ton Roosendaal (ton) added a comment.Via Old WorldMay 11 2011, 2:21 PM

Can't do this in current svn, OSX 32 bits. I use ortho view, zoomed out a lot.
Any more tips for how to reproduce precisely? Adding a .blend is really always advised, even when you think it's not needed. Blender just has too many settings that could cause issues in some combos.

Including blend file.


Steps to reproduce:

- Load factory settings
- "7" for top view of default box
- In user preferences enable continuous grab
- "N" to view transform values from left panel (Included blend file is at this point)
- Select the box and use "G" grab
- Move box by continuously dragging left or right
- At this zoom level, the transform value jumps at a little past +/- 360

Reuben Martin (fishb8) added a comment.Via Old WorldMay 11 2011, 7:58 PM

Latest SVN build, Linux x86_64 is similar, but different.

It reaches approx +/- 710 and then flips from negative to positive (or vice-versa depending on your direction). So if you move far enough in one directions you end up back where you started. :D

I would guess that the interactive transform tools uses signed values to store the differences in the transform made by the user and what I am seeing is different results between the two platforms when the transform value goes out of range of what the variable type can handle.



Ton Roosendaal (ton) added a comment.Via Old WorldMay 12 2011, 4:18 PM

Campbell: issue with continuous grab, should be nice one for you :)

The limitation has been removed within blender but Xorg still clamps to short internally.
reported to xorg:
https://bugs.freedesktop.org/show_bug.cgi?id=37244

closing since its a limitation of Xorg, and this is not an very common problem.

Campbell Barton (campbellbarton) closed this task as "Invalid".Via Old WorldMay 16 2011, 7:13 AM

Add Comment