Renderlayers + group instances use the group layer (not the group instance) for visibility check
Closed, ResolvedPublic

Description

Please unzip render_layer_group_bug.zip:
//render_layer_group_bug.blend - main file, the one to show the bug
//group.blend - group used in the main file, simple file with a group in the layer 11

If you render the file you will see that you can't see the group instance, or the group elements in the Particle object. Nevertheless (fun bug bonus) the shadow of the particle elements is there.

To "fix" this I can go to the RenderLayer I'm using and include the layer 11 (which is not needed for the 3dview). Or go to the group.blend file and move the group to layer 1.

* also attached are the render and 3dview.
** Windows 7, 64bits, home built, after 2.57 (36957)

ton (Ton Roosendaal) added a comment.Via Old WorldJun 7 2011, 7:22 PM

Will check later.

ton (Ton Roosendaal) added a comment.Via Old WorldJun 11 2011, 2:40 PM

The error is caused by new options for group instancing for particle systems. Without particle system things work expected.
Moving it to Janne's desk!

dfelinto (Dalai Felinto) added a comment.Via Old WorldJun 12 2011, 9:20 AM

Ton, the problem is not particular to particles. The group with Suzanne, a cone and a torus does not render. And it's simply an empty with a group instance with no particle at all.

ton (Ton Roosendaal) added a comment.Via Old WorldJun 12 2011, 12:40 PM

I deleted the particle system and then the group renders OK

great finding Ton. I attached a new file that shows the problem in one single file.
The group is in Layer 11 (hidden by default). Unless you turn layer 11 on in the RenderLayers you dont render it (although in 3dview it's always visible)

zeauro (ronan ducluzeau) added a comment.Via Old WorldAug 17 2011, 8:13 PM

ubuntu 64bits, rev39483
I can render the cube with the little suzannes in render_layer_group2.blend.
You just have to enable in RenderLayers Layer1 and 11 for Layers buttons.

If I delete group and readd a group instance in render_layer_group.blend. The whole scene is rendered.

sergey (Sergey Sharybin) added a comment.Via Old WorldApr 3 2012, 3:19 PM

So, what's the status of the report?

ton (Ton Roosendaal) added a comment.Via Old WorldOct 21 2012, 3:28 PM

Almost closed this as "part of unmaintained code". But - it is render code, which I should be able to check :)
Fix goes to svn!

Error was that the particle duplicator was setting the group instance layer (11), not the particle system layer to duplis.

ton (Ton Roosendaal) closed this task as "Resolved".Via Old WorldOct 21 2012, 3:28 PM

Add Comment