Page MenuHome

Jack enabled = 11 second delay in creating new file.
Closed, InvalidPublic

Description

Ubuntu 11.04 64-bit

Blender 2.58.1 r38032M

Jack Version: 0.3.7
Build: Dec 5 2010 02:50:30

--------------------------------------------------------------------
--------------------------------------------------------------------

Open Blender > Load factory defaults > save user preferences.

Close Blender, and then re-open > go to user prefs. > enable Jack > save as default > click 'New' = 10/ 11 second delay, interface freezes and then a new scene is created. No errors in the console.

Warning: I'm not too sure if this is down to JACK not being set-up on my machine correctly, I have had it woring between Blender & Ardour with out a hitch, but I'm not 100%. Perhaps Blender is having trouble talking to the JACK server when creating a fresh scene or something along those lines.


Details

Type
Bug

Event Timeline

I couldn't redo the problem on Ubuntu 11.04, but I'm also not familiar with how this is supposed to be set up. If there is anything else running besides blender (jack server, ardour, ...), some details about that might help tracking this down.

Assigning to our audio developer Joerg.

Hmm, I cannot reproduce the problem.
Do you start your jack server manually? Is any interesting output there?
Maybe it's somehow related to pulseaudio?

I think it may actually be due to the jack server not starting.

Since I get no feedback from Blender (I can't figure out how to get the console up in Ubuntu) I wasn't too sure what was happening.

But now that I've played around with both Ardour & Blender I think Blender does not start the jack server, where as Ardour does. If I start Blender before Ardour I get an error message from Ardour saying something about not being able to use the jack server, and it closes, and this is when Blender has the pause issue.

However when I start Ardour first and get a project loaded up, and then start Blender, set it to AV-syn, and enable JACK in Ardour everything works fine, and from what I remember Blender does not pause when clicking file new.

If I can figure out how to get the console up I can post the error messages, if any, but by the sounds of it I'm guessing it's something to do with my system/ set-up.

You're right, I tried this out without starting jack. And yeah blender hangs when it fails to start jack, but this is normal and expected behaviour by jack, nothing we can change here. I recommend you to use jack professionally and use a server frontend like qjackctl to start the jack server before you start any application that uses jack.

Closing.

Joerg Mueller (nexyon) closed this task as Invalid.Jul 8 2011, 2:24 PM