Paricles show in multiple (incorrect) locations when rendered
Closed, ArchivedPublic

Description

I refer to these out of place particles as ghost or phantom particles for lack of a shorter, more accurate name.

Open the blend file and go to frame 5
press F12 to render
you should see the ghost particles similar to the what you see in the video linked below
if not, go another 5 frames and render
repeat until you see the ghost particles in the render

If you still cannot see the issue, here is a video that shows it:
http://www.youtube.com/watch?v=WQ8T4SB5ElU

have consistently reproduced the issue on 5 different computers, with different versions of blender, on both Windows and Mac

It may also be worth reading though my thread on blenderartist.org. There is a link to an old blend file that should show the same issue, though the one i uploaded here produced the issue more constantly:
http://blenderartists.org/forum/showthread.php?207676-phantom-particles

Mike Pan (mpan3) added a comment.Via Old WorldAug 15 2011, 9:15 PM

I've noticed that behavior too in some of my work. The temporary solution is to select the particle emitter object, go to the particle property setting, and click on Bake. This will precalculate all the particles, which seems to solve the phantom particles bug.

But it does seems like a bug to me.

Jeff H (gun4hire) added a comment.Via Old WorldAug 15 2011, 10:39 PM

Thanks Mike. I was aware of this workaround (actually i think it was you who told me before). But if you try this workaround on the provided blend file, you can see another bug that i have come across many times in the past on earlier versions of blender as well as 2.59.
After baking, play the animation and you can see some random particles that seem to be rushing towards the emitting mesh in rhythmic waves.
here is a video that shows it:
http://www.youtube.com/watch?v=Msua2mxjnro

i dont know if this is related to this bug report. I can fill out another report if you want. However, this bug does seem to be related to cache steps. when set to "1" before you bake you dont see the bug.

Miika Hamalainen (miikah) added a comment.Via Old WorldSep 12 2011, 6:38 PM

Both issues seem to be related to the 3D view display percentage setting. Regarding the original report, I suppose you missed the "Display percentage makes dynamics inaccurate without baking!" message in particle settings? :)

But agreed, this is clearly an issue and should be fixed.

Ton Roosendaal (ton) added a comment.Via Old WorldOct 21 2012, 5:38 PM

Yeah... but we suffer lack of maintenance here. In many ways we should consider the current particle as "as is" and move our hopes to the new system from Lukas. :)

Since a workaround exists, I marked this error on our wiki todo list for future reference.
http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Tools#Particles

Ton Roosendaal (ton) closed this task as "Archived".Via Old WorldOct 21 2012, 5:38 PM

Add Comment