Home

Particle Texture Influence Bug (3)
Closed, ArchivedPublic

Description
Particle Size Texture Influence Bug

This file shows a simple particle system that uses a (blend)texture to change the size of the particles.

To try it out:
Press Alt-A to play the animation
Move the Empty around to see the particle grow and shrink with the empty


The problem:
Right now, The particle system needs to be set to 'Newtonian Physics' for texture to influence the size, and with global gravity turned off.

Wishlist:
It would make sense if the size influence could work with the Physics set to 'None'. That should save some computation time and avoid hacks such as setting gravity influence to 0.
Even better if the particle system can update without having the animation being played-back.


Thanks
jhk (Janne Karhu) added a comment.Via Old WorldAug 15 2011, 9:32 PM
Assigned to self for investigation.
dfelinto (Dalai Felinto) added a comment.Via Old WorldAug 17 2011, 12:42 AM
I actually found a new bug with this.
The texture driven by the object is only working in the 3dview :/

(0) open the file Mike prepared
(1) render it
-- result is different than 3dview
(2) select the plane and go inside/outside edit mode
-- it changed in 3dview back to the correct distribution.

[repeat (2) and (3) ad eternum]
gun4hire (Jeff H) added a comment.Via Old WorldAug 17 2011, 2:56 PM
I can confirm what Dalai Felinto is saying. It may even be related to the bug i reported:
http://projects.blender.org/tracker/index.php?func=detail&aid=28116&group_id=9&atid=498

They are both kind of the same idea: particles rendering different then what you see in the 3dview.
ton (Ton Roosendaal) added a comment.Via Old WorldOct 21 2012, 6:32 PM
Well ehh... this seems to be more an issue than the one I just closed.
Or is it dependency graph?
ton (Ton Roosendaal) added a comment.Via Old WorldFeb 16 2013, 5:51 PM
Merged with this report:
http://projects.blender.org/tracker/index.php?func=detail&aid=28919&group_id=9&atid=498
ton (Ton Roosendaal) added a comment.Via Old WorldFeb 16 2013, 5:52 PM
Merged with this report:
http://projects.blender.org/tracker/index.php?func=detail&aid=30205&group_id=9&atid=498
sergey (Sergey Sharybin) closed this task as "Archived".Via WebMay 29 2014, 9:42 AM

Particles are one of the things which are gonna to be re-worked as a part of the Gosseberry project. Seems this is not really a regression (or at least regression happened ages ago), so moving it to TODO http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Tools#Particles

We'll address all the limitations/bugs at once with new particle system. Thanks for the report anyway!

Add Comment