Home

Property Editor hides properties
Closed, InvalidPublic

Description
Found in Blender 2.59

In some cases, the property editor does not show properties of an object because they are scrolled out of sight, yet there is no scrollbar, looking like there are no properties available at all.

1) In the properties editor, go to any object related context that extends beyond the window size, so you have to scroll to see all, like Material or Particles (with added PS)
2) Scroll down to the bottom of the context
3) Delete the object whose properties you are currently in
4) Create a new object that can have the same properties like the one you just deleted (e.g. no Lattice when you were in Material tab, since lattices can't have materials)
5) In the properties editor, the new object will display the context that you were in last on the deleted object, also referencing the position you scrolled to. But since there are e.g. only empty Material slots, the contents of the context do not reach down as much as for the deleted object, therefore the tab seems empty unless you MMB-click and scroll or press POS1 to get back to the top or if you're in windowed mode, just move the program window.

This happens especially in Particle(with active PS) and Material context, because they regularly are much longer vertically, but in principle, this could happen in any context (e.g. when adding lots of Custom Properties). Probably this is also depending on available screen space/resolution, so if you can't get it to work on a 30" display, perhaps reducing vertical blender program window size makes the problem more likely to happen.
georg (Georg K) set Type to Bug.Via Old WorldAug 22 2011, 7:40 PM
georg (Georg K) added a comment.Via Old WorldAug 23 2011, 5:15 PM
And by POS1 I mean "Home" on QWERTY keyboards.
ton (Ton Roosendaal) added a comment.Via Old WorldAug 27 2011, 6:34 PM
This has been reported before... we realize it's awkward

The reason is that the scroll bar status is stored in the property view, to allow clicking around in UI and inspect values.
If we would reset the scrollbar on clicking objects without these properties, you'd need to scroll back to the bottom when you return to an object with (for example) particle properties again. People found that annoying too.

I can see both side arguments though, especially to show an empty view without scrollbar is ugly. Will check if this can be done more elegantly.
georg (Georg K) added a comment.Via Old WorldAug 28 2011, 6:32 PM
Sorry, I have not found a duplicate report with the search.

Assuming that the deletion of an object is the only way to trigger this bug: As some kind of a compromise, what about resetting the scrollbar when an object is deleted ? Since in this case the property editor is automatically changing to world context, it would be necessary to go back to the last context anyway, doing a second step to find the last position would not be such a big deal.
From a workflow point of view, I think that a deletion probably is the end of an activity that required access to the same properties on multiple objects, so it would not interfere with most users way of doing things.
Not so sure what to do if the context is pinned, though.
krash (Anthony Edlin) added a comment.Via Old WorldNov 27 2011, 8:42 AM
Deleting the object isn't the only way to reproduce this bug.

This could be marked and closed as a duplicate of this bug: http://projects.blender.org/tracker/index.php?func=detail&aid=24343&group_id=9&atid=498
ton (Ton Roosendaal) added a comment.Via Old WorldOct 21 2012, 6:34 PM
closed as duplicate, will work on the other one.
ton (Ton Roosendaal) closed this task as "Invalid".Via Old WorldOct 21 2012, 6:34 PM

Add Comment