Page MenuHome

Collada export, broken animation track name IDs
Closed, InvalidPublic

Description

Trying to export some armature based animation, the following is exported:

-snippet-

<animation id="tiras_009_pose.bones["C Hip"].location_X">
<source id="tiras_009_pose.bones["C Hip"].location_X-input">
<float_array id="tiras_009_pose.bones["C Hip"].location_X-input-array"
<technique_common>
<accessor source="#tiras_009_pose.bones["C Hip"].location_X-input-arr
<param name="TIME" type="float"/>
</accessor>
</technique_common>
</source>
[....]

<sampler id="tiras_009_pose.bones["C Hip"].location_X-sampler">
<input semantic="INPUT" source="#tiras_009_pose.bones[&quot;C Hip&quot;
<input semantic="OUTPUT" source="#tiras_009_pose.bones[&quot;C Hip&quot
<input semantic="INTERPOLATION" source="#tiras_009_pose.bones[&quot;C H
<input semantic="IN_TANGENT" source="#tiras_009_pose.bones[&quot;C Hip&
<input semantic="OUT_TANGENT" source="#tiras_009_pose.bones[&quot;C Hip
</sampler>
<channel source="#tiras_009_pose.bones[&quot;C Hip&quot;].location_X-samp
</animation>

-end of snippet-


Details

Type
Bug

Event Timeline

assigning to myself for further investigation.

Collada bugs are not being handled well so far,

for this reason they are all being set as \'TODO\' and linked from our wiki page.

http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Import_Export#OpenCollada

This tracker item can still be updated with useful info and closed (removed from the page above) when fixed.

Hi, Juan,

Can you still reproduce this bug? If so, could you provide a sample file?

I encountered this problem today (using 2.63). I had previously been exporting actions one at a time without problem, but it started adding a massive swath of broken animation nodes as described above. It turned out the exporter was creating them for a number of objects I'd accidental linked the action data blocks to (literally by selecting the action in the action editor whilst having an object other than the armature selected.).
The 'broken' animation nodes are exported along with the object the block is linked to, resulting in a situation where it will create them even if you only export a mesh without it's armature (or even delete the armature, I found).

I was able to fix this behaviour for myself by unlinking all of the actions, then exporting with a single action selected on the armature.

@Juan Linietsky: I have permanently closed this issue, because there is no indication that it is still a problem. However if you find your problem is still not solved in Blender 2.68 or newer, then please feel free to attach a demo blend file to this report so we can reproduce the problem and fix the issue.

-gaia-

Gaia Clary (gaiaclary) closed this task as Invalid.Jul 30 2013, 2:39 PM