Mouse Over doesn't work at certain angles
Closed, ResolvedPublic

Description

The attached blend file contains a very simple game of Ludo.
I can move the blue pieces all the way round the board by clicking on them, but the red pieces refuse to move. The weird part is, if I rotate the board 180 deg I can now move some of the red pieces some way and some of the blue pieces some way.
Note1: The game logic is not complete
Note: My OS is Win32 bit, not 64 bit as the system-info file says

--
Best regards
Stefan Kristensen

Details

Type
Bug

Moved from Blender 2.5 Bug Tracker to Game Engine

moving to game engine tracker.

Hi,

Tried looking at this for a bit, I think the issue is orthographic mode without an actual camera, the mouse cursor raycast is done from perspective mode's camera position onward and not from "infinity" as orthographic view suggests. Have to research it a bit more, now it seems to me that the camera settings are heisted from the only actual cam in the scene. Perspective mode should work as it is, orthographic should work with an active camera.

Hi,

I put a patch in the patch tracker with a fix for this and some small issues related to it; http://projects.blender.org/tracker/index.php?func=detail&aid=28893&group_id=9&atid=127.

fixed by Juha at rev. 41131 (after 2.60)

Dalai Felinto (dfelinto) closed this task as "Resolved".Oct 20 2011, 8:44 AM

This patch introduced -far +far when using 3dviewport camera (while fixed the same issue in the projection code itself).
I believe the right is to use +near +far all the time.

I didn't test the old files, but committed a suppose fix for 3dviewport in rev. 54733
(got to it while tracking back on old bug on using stencil with bgl working in 2.60)