Page MenuHome

Unable to Load Movie File and/or Crashes *NEEDS RE-TEST*
Closed, ResolvedPublic

Description

VSE Bug Number One: Crashing Galore

On some files when I try to open them in the file browser, as soon as I click them, poof. Blender crashes. Not only that, if I even as much as VIEW the folder the offending files are in in Thumbnail mode, Blender crashes too. Ubuntu says that a few of the files are unreadable, that it can't decode the JPEGS. Those are the ones that crash Blender. It's weird, because this never happened with the official 2.59 Release, and Graphicall buids from before then, which actually plays the corrupted files PERFECTLY. This bug must have been introduced somewhere between r39307 and r39367
When there's a problem, it should at least display an error message. Which leads us to our next bug.

VSE Bug Number Two: "...could not be loaded"

This bug is almost identical to the last one, except just displays an error message. This happens to every video file that doesn't lead to a crash.


Crasher file: http://www.megaupload.com/?d=9R5A08AT

Computer Specs:

8GB RAM
Linux Ubuntu 64
Intel Core2vPro


Details

Type
Bug

Event Timeline

Oh, if you want to get around megaupload's wait time, go to http://www679.megaupload.com/files/7909d4644da2a12157b9272cbaa59aed/Gearthrec.mp4.ogv

Oh, nevermind. Megaupload's too smart.

@Kelvin, from reading the report, you didnt give any way to redo the crash since the file you link to is only not loading (rather than crashing), if I understand correctly.

Can you upload the files which cause the crash please?

Actually, the file I link to is the file that causes the crash. I didn't provide any of the files that don't load, because I haven't had any file that works, so I guess no video loads. MP4s, OGVs, etc. Maybe a library issue, I suspect?

If you want, here's one of the files that don't load: http://www.mediafire.com/?vu5zhjtev4cgski

Gearthrec.mp4.ogv and earth.ogv both preview and load fine here,
64bit linux 40767.

Kelvin, almost the same bug was recently fixed in our build environment. This bug was caused by FFmpeg incompatibility with 64bit and newer gcc (4.6 and probably 4.5). If you're building Blender yourself, make sure you're using FFmpeg compiled with gcc-4.4 (not sure about other distros, but in Debian official and debian-multimedia repos FFmpeg is compiled correct and doesn't crash).
You can also try to use build from our automated build bot: http://builder.blender.org/download/

Tested again, works fine. You guys can close this now. :)

Closing report. Thanks for report and testing :)

Sergey Sharybin (sergey) closed this task as Resolved.Oct 4 2011, 10:24 AM