problems with macbook's trackpad
Closed, ResolvedPublic

Description

Hi, while Blender 2.5x including 2.60 RC2 works really well on a Mac and is better integrated with OS X than 2.4x ever was, there is one issue with Macbook trackpad - when you scroll the view with 2 fingures gesture, the view sometimes zoom in or zooms out really fast (I've attached short video to show you what I mean). It's when you scroll a little faster then normal. Only Blender acts like this - all other apps on a Mac don't react this way.

While trackpad is sensitive to speed of the gestures, it is a strange behaviour - the view shouldn't zoom in/out when you scroll - and even then, not as fast as in the video. Macbook's trackpad is very precise and easy to use. From time to time I even use it in graphic software. In Blender, becuase of this bug mentioned, it is more difficult to use it.

mallow (Krzysiek Slazinski) added a comment.Via Old WorldOct 15 2011, 11:11 AM

I've had problems uploading the video on blender.org. Here's the YouTube version:
http://www.youtube.com/watch?v=UnuA-RmrLrY

The last zoom in/out on the video is with pinch to zoom gesture. The first two are wrong behaviour of the scroll gestures.

sergey (Sergey Sharybin) added a comment.Via Old WorldNov 4 2011, 12:28 PM

Jens, maybe you've got some ideas about this issue? Thanks.

jensverwiebe (jens verwiebe) added a comment.Via Old WorldNov 4 2011, 2:03 PM

Hi
I know this comes from lifting fingers accidently, which causes the gesture to switch to softdscroll->zoom.
I noticed this changed from OSX 10.6 -> 10.7 where also the magicmouse "wheel/pad" behaves like a gesture now ( same as 2 finger pan ).
Must see if timing tweaks can help here, but i fear we should soon go for NSTouch api to track all these new events better.
Disadvatage: it´s only available for 10.6 and higher.

Jens

ironmagma (Philip Peterson) added a comment.Via Old WorldMar 22 2012, 10:54 PM

Not only is this caused by "accidental" lifting of the fingers, but generally users want to use the "swipe" gesture, where you intentionally lift your fingers off the trackpad (because you've run out of room) and expect it to continue scrolling out of momentum. This is pretty much universal for gesture apps I've seen (Preview, browsers, Photoshop).

sergey (Sergey Sharybin) added a comment.Via Old WorldApr 3 2012, 3:45 PM

Jens, might it be NSTouch used only for >=10.6 builds, but 10.5 still use current behavior?

dingto (Thomas Dinges) added a comment.Via Old WorldOct 2 2012, 9:27 AM

Any updates here?

jensverwiebe (jens verwiebe) added a comment.Via Old WorldOct 2 2012, 10:12 AM

No work done yet, i thought Mike Erwin could have a look whereas NDOF workout.

Jens

ton (Ton Roosendaal) added a comment.Via Old WorldOct 21 2012, 7:12 PM

I might have access to a new macbook in a couple of weeks, will check it then.

brecht (Brecht Van Lommel) added a comment.Via Old WorldNov 10 2012, 9:10 PM

I had an issue like this in Safari, where it would freeze when accidentally doing an extreme pinch zoom with the trackpad. It got fixed in an update though, not sure if this issue is the same but it may well be that this is an operating system bug. I don't see much room for this to go wrong in Blender itself. In any case it would be good to confirm if this issue still exists even.

brecht (Brecht Van Lommel) added a comment.Via Old WorldNov 10 2012, 9:15 PM

Also, I can't redo this issue on a mid 2009 Macbook Pro with OS X 10.7.5, with Blender 2.61, 2.64 or latest svn.

Unless someone can confirm this issue still exists I suggest we close this report.

mallow (Krzysiek Slazinski) added a comment.Via Old WorldNov 10 2012, 11:56 PM

In my case the bug is still present. I've reported this over an year ago. Blender versions has changed couple of times. I've just tested this with Blender 2.64. I've also updated OSX to 10.8.2. It is still the same. Just like in this video I've posted (2nd message, link to YouTube video). When you scroll too fast, you get extremly fast zoom in/out instead of paning while using trackpad's scroll function. I've never had any issues with native OSX apps, none in Safari, none in Adobe software. Only Blender. So I don't think it is an OS issue nor the hardware issue. One may like or dislike Apple, but their trackpads work very very good.

Oh, and when I say "scroll too fast". In fact it is very easy to reproduce this bug. You have to scroll very slow NOT to reproduce it. I have no issues working with Illustrator or Photoshop with a trackpad when I have to, but Blender? External mouse is the only way because of this bug.

ton (Ton Roosendaal) added a comment.Via Old WorldDec 20 2012, 1:02 PM

Fix is in svn now. Here's the log I typed:

Mac OS X trackpad and 'mighty mouse' fix.

An old commit from Damien in 2010 tried to make mighty mouse touches work as if
this is a scrollwheel. The error in that code was that the "kinetic scrolling"
feature failed. When releasing your fingers, the events passed on to Blender
then switched from "trackpad pan" to "mousewheel zoom".

This commit makes trackpads and mighty mouse behave identical. Only difference
is that trackpad panning needs 2 fingers, mighty mouse only one.

Note that trackpad and mighty mouse 3d zoom works with holding ctrl!

All works nice with this kinetic feature now. Fun :)

ton (Ton Roosendaal) closed this task as "Resolved".Via Old WorldDec 20 2012, 1:02 PM
tuomassalo (Tuomas Salo) added a comment.Via Old WorldFeb 1 2013, 6:30 PM

Easy workaround! For me, this problem goes away if I change "with Inertia" to "without Inertia" in System Preferences -> Trackpad. I have a MacBook Air with Snow Leopard (10.6.8), and Blender 2.65.

mallow (Krzysiek Slazinski) added a comment.Via Old WorldFeb 1 2013, 6:37 PM

There is no need to change preferences anymore. Ton fixed this issue. Latest builds work great with a trackpad.

Add Comment