Z-Transp disables Material Pass Index
Closed, ResolvedPublic


when using a pass index for a material, enabling Z-Transparency to the material seems to disable the pass index.
So when you have a material set to Z-Transparent, the Render nodes don't render that materials Pass index anymore.

in the blend file, you'll see a viewer node, that would normally show the Pass Index. But it's blank because Z-Transparency is enabled.
Disable it for the material, to see the Pass appear in the viewer node.




Confirmed, assigning bug. Jeroen, it seems the z-transp material index pass in zbuf.c writes object index instead?

Any updates here Jeroen?

Sorry for the late response.
But it has been fixed in revision 51527.

Thanks for the report!

Jeroen Bakker (jbakker) closed this task as "Resolved".Oct 23 2012, 9:21 AM

Add Comment