Grease pencil datablocks
Closed, ResolvedPublic

Description

I perceive the following to be a buggy behaviour. However, it could be a limitation:

Every time you create a new grease pencil datablock (3D View - Properties sidebar), the current datablock seems to be linked to a fake user. So, if you:

1. Open default scene and start sketching.
2. Create new grease pencil datablock.
3. Activate the initial GP datablock.
4. Repeat steps 2 and 3 as many times as you wish.

This is what happens: when you drop down the list of datablocks, you see the initial GP datablock with multiple users (as many times as you repeated steps 2 and 3), and the same number of datablocks with 0 users. If the idea is to avoid losing these datablocks, one single fake per datablock should be created automatically.

Sorry if it's not a bug (seems I haven't been too good at reporting, lately).

Regards.

Pep.

Details

Type
Bug

For me it's not a bug, it's just how most of datablocks are behaving (i.e. object datablock). I don't think having fake users for gpencil datablocks would be useful. But it's Joshua who maintains this area, maybe he've got other opinion on this.

Fake users are not the issue, was just a bug in the code adding new datablock. Fix in svn, thanks for the report.

Brecht Van Lommel (brecht) closed this task as "Resolved".Nov 5 2011, 11:49 AM

Now it's working fine. However, I've got one question: is there any particular reason why a GPencil datablock cannot be made single-user when shared by 2 scenes, for instance? The "2" button appears disabled. Is this the expected behaviour?

It's not implemented for this datablock type, no particular reason, just that no one has gotten to this yet.

Ok, I see. Thanks for the fix!