Select before/after current frame deselects all channels in graph editor
Closed, ResolvedPublic

Description

This happens when "Only Selected Curve Keyframes" is active.

Blender 2.60a
Windows 7 64
ATI Mobility Radeon HD5740

Details

Type
Bug

Joshua seems to be busy last days, will try to help him. Assigning to self for investigation.

In fact, it was intended in code to deselect all channels when running this operator.
Maybe it was reason for this, so Joshua, can you glance at attached patch? Thanks.

Fixed in svn.

Noted some other todo issues here, but those are probably not as critical as the primary issues here, so I'm calling this report closed to get the tracker under control agian.

Joshua Leung (aligorith) closed this task as "Resolved".Nov 12 2011, 6:02 AM