Subsurf slow performance
Closed, ResolvedPublic

Description

Blender 2.6x revision 41987 win7 64 bit Ati Radeon Mobility 5650 1gb Core i7 1.7 (2.6ghz turbo boost)

Runing Blender over the demo files (demo loop 26 archive) i found that bmw249 , sintel_lite , cataphract , blenderella_topology performs
very slow ranging like :

- bmw249 3 fps
- sintel_lite 5 fps
- cataphract 20 fps
- blenderella_topology 20 fps

If loading blenderella_topology.blend and apply the subsurf modifier i get 60 (modified only the framerate of the blend to get more fps counted from maximum 24 ) fps instantly from 20-23 max (that with turbo boost on).

If i put on it armature modifier , add a bone , add a vertex group to it and press ALT-A to animated , guess what ? I get from 60 fps down 29 fps instantly and that with only one bone.

What happens with Modifiers that are so cracking down the performance ?! It happens with subsurf LVL 1 and optimal display does nothing.

Guess what if i add subsurf modifier (20 fps) then add smoth modifier then go to subsurf and set lvl 6 view i get 60 fps on two views on screen. Same happens if i add mirror modifier , edge split instead of smoth modifer. Edit mode performance is steady at 30 and looks not afffected so much.

It clearly something happening with subsurf modifer.

I hope this will be solved.

* I did not want to report it but found that i can import a mesh of 1.7 m verts and can`t animate a mesh of 100k going down after 1 subsurf lvl 1.

Details

Type
Bug

This bug plague armature modifier , subsurf ....

Tested more and looks it plagues even Edit mode and can go to 10 fps from 60 fps (after applying sub surf)

Fixed what I think is the main cause of slowdown now in the blenderella file. For the other files, if something draws slow, that's not a bug necessarily, and small performance differences are expected with/without subsurf modifier. Adding an armature modifier for example might mean the mesh is now animated, so needs to be recomputed every frame.

Brecht Van Lommel (brecht) closed this task as "Resolved".Nov 21 2011, 4:04 PM