Node lines are not drawing correct
Closed, ResolvedPublic

Description

Hi Lukas,

as discussed, here is the report:

My specs
-------------
Ubuntu 64 bit
Intel I5
Intel i915 Graphics card

It happens in:
----------------------
Newest build from trunk (r42189), but also in the official prerelease 2.61 version.

Description:
--------------------
The lines between the nodes are not drawn correctly.

How to reproduce it:
-----------------------------
Open the supplied blend - you should immediately see the missing lines (every node should be connected) - Compare the uploaded images (attaching or at the following positions)

Old revision on my card draws correctly:
http://www.pasteall.org/pic/show.php?id=21522

New revision on my card does not draw correctly:
http://www.pasteall.org/pic/show.php?id=21524

Generally, I'm able to reproduce it always, when I try to connect some nodes with a mix node to an output.

Greetings, Thomas

Details

Type
Bug

Everyone who has the same problem: Please comment here with your specs! We need more input on this!

Hi Lukas,

please take a look at the following code: This works flawlessly...let's talk about it on monday!

http://www.pasteall.org/26816/c

I'd rather not remove the color progression along lines here ... It's not a crucial feature from a technical standpoint, but one that should work.

Sorry i can't give you a better solution, just can't reproduce it.

It looks like another inter driver bug, will leave the report on investigate to see if other people have the same trouble with that hardware.

Added a possible fix using GL_LINES instead of GL_LINE_STRIP for the shaded part, let me know if this works (node_line_draw_shaded.diff).

Lukas, that works! Ready for checkin :)

Campbell suggested it might work by enabling GL_BLEND. Should not be necessary either (no blending with background pixels required), but just out of curiosity can you test node_line_draw_shaded2.diff ?

Intel i5 64 bit ubuntu 11.10 - intels on processor graphics (hd?).

Start notice it already in 2.5x, in logic editor - but rarely and zooming in out solved it. Recently (in 2.60) visited the node editor and it was completely mad - most lines invisible and most of the rest only the drop-shadow. Came here to report and found this bug :-)

I've committed the fix for node line drawing (r42266).

@Lars: Could you make a second bug report about logic editor and include a screenshot and test file (even though i probably can't reproduce either)? Thanks!

I will also send a note to bf-committers mailing list about this.

Lukas Toenne (lukastoenne) closed this task as "Resolved".Nov 29 2011, 8:52 PM