Page MenuHome

Record Animation runs 1000+ fps on Mac OSX 10.6.8 64bit
Closed, ResolvedPublic

Description

While attempting to bake a physics simulation, the record to animation function runs the game engine at over 1000 fps. I've changed the settings in the physics window, the world window, and "blender render" fps. No change. If I increase the physics steps to 5 it slows the fps to between 300-500 fps on average.

Also the initial object state is lost through the recording processes (after 2 or 3 cycles). Example: If you record, go back to frame 1 and record again, the simulation seems to start at the last recorded frame/ object state of the previous recording.

I'm using a Mac Pro tower with bootstrapper (both Mac osx 10.6.8 64bit, and Win 7 64bit). Both MAC and Win on this machine show the same problem. Processors are 2 x 2.26ghz quad-core intel Xeon.

Details

Type
Bug

Event Timeline

can you please attach a sample file? ideally one that works fine in 2.49 (if that's the case).
It can be one file per problem or one that shows both.

(removing "Mac OSX 10.6.8 64bit" from the description given that this is stated in the description and the problem also happens on windows).
//I haven't tested//confirmed this yet//

Thanks for the fast reply. I will not be able to provide files. However the problem exists when I run basic_physics_test.blend which is located in the phyiscs-2.57-physics-testsfiles on the blender download page. I'm using blender 2.60, 2.60a, 2.61 test build.

When not recording, the ball rolls down the ramp as expected, and engine runs at a smooth 60fps. When recording, the frame rate is around 300-1200 fps. When recording for the second time, the initial state of the objects (the ball and pins) is set to last frame of the previous recording.

This should now be fixed as of r45408. Could you please verify?

This was confirmed to fix the bug here: http://projects.blender.org/tracker/index.php?func=detail&aid=30484&group_id=9&atid=306, which looks to be a duplicate of this report. Therefore, I'm closing this report as well.

Mitchell Stokes (moguri) closed this task as Resolved.Apr 5 2012, 10:22 PM